summaryrefslogtreecommitdiff
path: root/dev-python/python-glanceclient/python-glanceclient-4.4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-19 09:38:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-19 09:38:07 +0100
commit4d9aef45678c7cb55b24107642790224ab8c153b (patch)
treeb1c56639785aeba23901272429a46e4e872a7711 /dev-python/python-glanceclient/python-glanceclient-4.4.0-r1.ebuild
parentf09a6cf772eb2f757f0fc49f3297d6a095a10aa5 (diff)
gentoo auto-resync : 19:08:2023 - 09:38:07
Diffstat (limited to 'dev-python/python-glanceclient/python-glanceclient-4.4.0-r1.ebuild')
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-4.4.0-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/python-glanceclient/python-glanceclient-4.4.0-r1.ebuild b/dev-python/python-glanceclient/python-glanceclient-4.4.0-r1.ebuild
new file mode 100644
index 000000000000..6d7d881d456b
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-4.4.0-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="
+ https://opendev.org/openstack/python-glanceclient/
+ https://github.com/openstack/python-glanceclient/
+ https://pypi.org/project/python-glanceclient/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/keystoneauth1-3.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-17.1.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/tempest[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ dev-python/testtools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ # functional tests require cloud instance access
+ eunittest -b glanceclient/tests/unit
+}