summaryrefslogtreecommitdiff
path: root/dev-python/python-gudev
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/python-gudev
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/python-gudev')
-rw-r--r--dev-python/python-gudev/Manifest4
-rw-r--r--dev-python/python-gudev/files/automake.patch10
-rw-r--r--dev-python/python-gudev/metadata.xml8
-rw-r--r--dev-python/python-gudev/python-gudev-147.2-r1.ebuild46
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/python-gudev/Manifest b/dev-python/python-gudev/Manifest
new file mode 100644
index 000000000000..ed8206140260
--- /dev/null
+++ b/dev-python/python-gudev/Manifest
@@ -0,0 +1,4 @@
+AUX automake.patch 210 BLAKE2B 4691012ba55e2d8534701ea7e2b083691259cb9514d79df70c94b60e3ce14c8a29071b4bf6c8bd8cee372af23ea49ad058298292f0414ccf13b6da1bc2ef3039 SHA512 14e23d7427a35946bf0b6e80f9a98b3240d91a9e40b41043f5cdf2faf90fd4f95af5e07b34d7bc4d8f38b1e541dea64d7ccde0d365c45cbfa102995501abdeb6
+DIST python-gudev-147.2.tar.gz 10111 BLAKE2B 52e5a87ec27c308a0e2679996187702d0852c1b173b477a51dbb6b4dfece69c7c4acb215f88432e85b1a31cb65a7b89246e4fe44ece18fd61898f62cebcb07b6 SHA512 a022df2989154ac5f358df7ff33d6f976cae4d005756c3b73937e0668751b923a29c3e1f813e89a7297653df7744f10207c2bb33d2a6816470ea2ca10975493f
+EBUILD python-gudev-147.2-r1.ebuild 1019 BLAKE2B 53f04f71a75c247fb6b19a3d091888f04cd32ebe69e18c45bcc267c05542c7e6bad68e144805c50bf012c8dedde0bdacdb774cf835cf4cb9a45f11034759cf6e SHA512 7d609b0338d015d4557b10e00facc2f46d48c4e10fb203b184f3caa4708e86c03139e356c7515cf9940688ebc6c03039dfc493abdbf7f70fe1e34550cb443e86
+MISC metadata.xml 249 BLAKE2B ce43f0670028937165ae8e9203849d8d45031fa55581f0ac4e3af4c498c96bede72d4333abf6dfc251738c8767f0511afbfb794917f16ad338080e04bf97ed1e SHA512 184548c150dc06fa334ae7e2efaa90a176d4dab5a04c0d3afe034bc4207272438041e814fba7f1c305beb154800c12d6d73c2fe04c76e83f1b11e305b5aea7be
diff --git a/dev-python/python-gudev/files/automake.patch b/dev-python/python-gudev/files/automake.patch
new file mode 100644
index 000000000000..a25c9e4fd31a
--- /dev/null
+++ b/dev-python/python-gudev/files/automake.patch
@@ -0,0 +1,10 @@
+--- configure.org.ac 2013-05-02 00:22:58.181214757 +0200
++++ configure.ac 2013-05-02 00:25:00.463686016 +0200
+@@ -8,7 +8,6 @@
+ AC_PROG_MAKE_SET
+
+ AC_PROG_CC
+-AM_PROG_CC_STDC
+ AC_HEADER_STDC
+
+ AM_PROG_LIBTOOL
diff --git a/dev-python/python-gudev/metadata.xml b/dev-python/python-gudev/metadata.xml
new file mode 100644
index 000000000000..4d742adbfbd6
--- /dev/null
+++ b/dev-python/python-gudev/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">nzjrs/python-gudev</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-gudev/python-gudev-147.2-r1.ebuild b/dev-python/python-gudev/python-gudev-147.2-r1.ebuild
new file mode 100644
index 000000000000..8e07b1e8ef14
--- /dev/null
+++ b/dev-python/python-gudev/python-gudev-147.2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=modules
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils python-r1 vcs-snapshot eutils
+
+DESCRIPTION="Python binding to the GUDev udev helper library"
+HOMEPAGE="https://github.com/nzjrs/python-gudev"
+SRC_URI="https://github.com/nzjrs/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="dev-python/pygobject:2[${PYTHON_USEDEP}]
+ virtual/libgudev:=
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/automake.patch
+ python_foreach_impl autotools-utils_src_prepare
+}
+
+src_configure() {
+ python_foreach_impl autotools-utils_src_configure
+}
+
+src_compile() {
+ python_foreach_impl autotools-utils_src_compile
+}
+
+src_test() {
+ python_foreach_impl autotools-utils_src_test
+}
+
+src_install() {
+ python_foreach_impl autotools-utils_src_install
+}