summaryrefslogtreecommitdiff
path: root/dev-python/python-jose
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/python-jose
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/python-jose')
-rw-r--r--dev-python/python-jose/Manifest2
-rw-r--r--dev-python/python-jose/python-jose-3.1.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-jose/Manifest b/dev-python/python-jose/Manifest
index dd6d5db9f951..1c31076a02c6 100644
--- a/dev-python/python-jose/Manifest
+++ b/dev-python/python-jose/Manifest
@@ -1,3 +1,5 @@
DIST python-jose-3.0.1.tar.gz 86726 BLAKE2B 82ad3cd1139b367d179e965aaf0e33f3592883da6b21ecb3a91e9fe98ff05dbe358e56156a3d34366ffc0d7bfa9efbcdef67c41307d803ac16144a0c0ac3570b SHA512 a39c3aa9acc6bcc0030e4435e499581043a820c54aa1a4b67ae478cf95f96f28755b03fa4453e484932a64865a61613a1ff4afe30249216e8f392638485693d7
+DIST python-jose-3.1.0.tar.gz 101693 BLAKE2B 1ee43ac5aef673f32c3d56e492784e28939b8f74a8232a83d31381b3f978d96ab132c94527df686b52f60c2865936ce022c2cd31ea66f009a83772d1389a7d4a SHA512 c4a04bed8fc17d65cb8fc9b2cf37996edb50fa0dcdc2dedd76a97c784f8af34a9c86748ea2f9ea348955ce780035fbe3a756abc8e1eb5e9b77ad57d411622c6b
EBUILD python-jose-3.0.1.ebuild 1204 BLAKE2B dc1a25484f1a36581090967e8dadaffe471cbe37360043b0ffaf88be4f3d7013bc4d3e436595de859ea0d6e66dcc951d6de326acbe5efd412286f735e7713af0 SHA512 2f892d605794ad628653fe3f2a99e713eb8caf27b50a5360253085f2eec14d56093ddfa584ec5b162264c169b3ecd5075062f998e2fcbf6c912f755180675544
+EBUILD python-jose-3.1.0.ebuild 1073 BLAKE2B 57c7d41573f7eacd7d1e1b46a8938fb7aba44b2ea5366d906d6ad3594d467e28f8abc0fa5343a93d49b0efdfb57937142786ac91f3c16114c079862d14af2512 SHA512 5964c83d903cf5935ba39312ace5a5d0db8592d9917b79e3fc174e515ae23ec0d79541ccc5457efde0b30f5b6db72b3143c25c5d1fc3f39ab2edfa7384b9df78
MISC metadata.xml 444 BLAKE2B f253d760dc81a5acb23c11eace88f17410135ebe2f336077e598b01f897e1a4304191feffdab06bdd5a04fb46430bbd090597a40e1ec96256865190a59a486fb SHA512 74ba057d1ffcb3d1995e1efe6436143260d8a973fe5cc9c1ffab0694932b2b3dd8eeccaf457a1d79fbb31f825b120fbc98fc3c0ad7b0796233e07df82357d160
diff --git a/dev-python/python-jose/python-jose-3.1.0.ebuild b/dev-python/python-jose/python-jose-3.1.0.ebuild
new file mode 100644
index 000000000000..87dfe24d778d
--- /dev/null
+++ b/dev-python/python-jose/python-jose-3.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="A JavaScript Object Signing and Encryption (JOSE) implementation in Python"
+HOMEPAGE="https://github.com/mpdavis/python-jose https://pypi.org/project/python-jose/"
+# pypi tarball lacks unit tests
+#SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/mpdavis/python-jose/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ >=dev-python/pycryptodome-3.3.1[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e 's|'\''pytest-runner'\'',\?||' -i setup.py || die
+ distutils-r1_python_prepare_all
+}