summaryrefslogtreecommitdiff
path: root/dev-python/python-json-logger/python-json-logger-2.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-15 14:01:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-15 14:01:09 +0000
commitdfa2037f41649c9775d690a3d01cfd5cabf4db71 (patch)
tree261884874fd25b6a9bff06b2e5f6106d091e3848 /dev-python/python-json-logger/python-json-logger-2.0.6.ebuild
parent8ba94db1fe69019bb2d3b4f50fe9d1ccf3d94b3a (diff)
gentoo auto-resync : 15:02:2023 - 14:01:08
Diffstat (limited to 'dev-python/python-json-logger/python-json-logger-2.0.6.ebuild')
-rw-r--r--dev-python/python-json-logger/python-json-logger-2.0.6.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/python-json-logger/python-json-logger-2.0.6.ebuild b/dev-python/python-json-logger/python-json-logger-2.0.6.ebuild
new file mode 100644
index 000000000000..3cf33e8f9d0d
--- /dev/null
+++ b/dev-python/python-json-logger/python-json-logger-2.0.6.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Standard python logging to output log data as json objects"
+HOMEPAGE="
+ https://github.com/madzak/python-json-logger/
+ https://pypi.org/project/python-json-logger/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests unittest