summaryrefslogtreecommitdiff
path: root/dev-python/python-jsonrpc-server
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /dev-python/python-jsonrpc-server
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'dev-python/python-jsonrpc-server')
-rw-r--r--dev-python/python-jsonrpc-server/Manifest2
-rw-r--r--dev-python/python-jsonrpc-server/files/python-jsonrpc-server-0.3.4-Python-3.8-fixes-for-endpoint-and-tests-37.patch84
-rw-r--r--dev-python/python-jsonrpc-server/files/python-jsonrpc-server-0.3.4-remove-pytest-cov-dep.patch15
3 files changed, 0 insertions, 101 deletions
diff --git a/dev-python/python-jsonrpc-server/Manifest b/dev-python/python-jsonrpc-server/Manifest
index 6ad4216040f5..6d91039f5f8f 100644
--- a/dev-python/python-jsonrpc-server/Manifest
+++ b/dev-python/python-jsonrpc-server/Manifest
@@ -1,5 +1,3 @@
-AUX python-jsonrpc-server-0.3.4-Python-3.8-fixes-for-endpoint-and-tests-37.patch 3003 BLAKE2B 9b4cb5168bd591a8832ddc3bcb14797adb58b5acbf5d4be22d7a6d5e559ea32013670417e15005c123d4d322e4af53b866cef0ddcf2f9a1720d200686e11ece9 SHA512 599cb7561e1fdee594f9059a6a669725e6b0d1909309bec28ede40d47a0e2a151f419011279cd8823d4a2946499696d240d099b9947784d19dc457279db20c20
-AUX python-jsonrpc-server-0.3.4-remove-pytest-cov-dep.patch 359 BLAKE2B 73548cee569f25bfd6cf98897ab5553507adb4e2f28a2cad6029451432f2144a8de2643bec491a1937f88fc2b7bb3a2f23dd1b56bc82eaec94f206fbdf0b133a SHA512 d8a7ac71a897d4dce9290b51a658443e5b6c954e38cd8477a55a5e3b8abaabf033a9f34410eb282156340efed36758a904eb2473a91b01fa181615fd8a641761
AUX python-jsonrpc-server-0.4.0-fix-test-with-ujson-3-and-up.patch 341 BLAKE2B 99635861a87bcc613540c0440edba10a3011c43ddfe91e675483db603308a655b8b77a832fc013016c7d3d0fe1dbe7c02f925dfc6b20cb514a37ca3d66c3dafa SHA512 3da608b3c7ed162d2b32c93f2f0733cc26e3ae218c65d3000d607a553240baef8ea47cddd8323caa58fea2fec59e8bf3f9b120a977b4522642b88ae55cf88f28
DIST python-jsonrpc-server-0.4.0.tar.gz 26491 BLAKE2B 524dbd0692861bff538d9db06facda4bdad74c84d3c047a374db658adc31eeb799ba0c4b0219597b04c75cd6e2db3968ba0cf4084ba235509c2457c22b3e1497 SHA512 062e5b75253b95e64918a9da86ad7e29d8a29019670e451b9a28d44cde064339953004c343be0e7dd40968ec9fc2420b5722265f56c2db8057d0f1eaf088dacc
EBUILD python-jsonrpc-server-0.4.0-r1.ebuild 821 BLAKE2B e3f5797334c29a39ccfaac7efe5ecd26901ec677f4708a82b8f1d4cae55e9fbf3b18c480cbb218006479788c39c224aefc6995227984281214b07e09f24e84cb SHA512 86e60b631f68bdc81b4ec53d0a26441d8a2369d713703808ca37f234680610a02ea5cbb7c6d026e0cb95abd58dfe4e17a09bdc005d513c2b7b754c6b4aa2cda8
diff --git a/dev-python/python-jsonrpc-server/files/python-jsonrpc-server-0.3.4-Python-3.8-fixes-for-endpoint-and-tests-37.patch b/dev-python/python-jsonrpc-server/files/python-jsonrpc-server-0.3.4-Python-3.8-fixes-for-endpoint-and-tests-37.patch
deleted file mode 100644
index 8d597ddda03f..000000000000
--- a/dev-python/python-jsonrpc-server/files/python-jsonrpc-server-0.3.4-Python-3.8-fixes-for-endpoint-and-tests-37.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-From 7987e30c99edddab8acbf567bad0ebf2d1c3381d Mon Sep 17 00:00:00 2001
-From: Ben Greiner <code@bnavigator.de>
-Date: Mon, 17 Aug 2020 21:28:03 +0200
-Subject: [PATCH] Python 3.8 fixes for endpoint and tests (#37)
-
-* fix endpoint exception lists for Python 3.8
-Author: @maximbaz according to #33
-
-* fix test_writer_bad_message
-not only windows can have problems with serializing datetime
-
-Co-authored-by: Carlos Cordoba <ccordoba12@gmail.com>
-Co-authored-by: Marko Bakovic <delta003@users.noreply.github.com>
----
- pyls_jsonrpc/endpoint.py | 1 +
- test/test_endpoint.py | 4 ++--
- test/test_streams.py | 19 +++++++++----------
- 3 files changed, 12 insertions(+), 12 deletions(-)
-
-diff --git a/pyls_jsonrpc/endpoint.py b/pyls_jsonrpc/endpoint.py
-index e8bfb5b..0caf612 100644
---- a/pyls_jsonrpc/endpoint.py
-+++ b/pyls_jsonrpc/endpoint.py
-@@ -236,6 +236,7 @@ class Endpoint(object):
- if error is not None:
- log.debug("Received error response to message %s: %s", msg_id, error)
- request_future.set_exception(JsonRpcException.from_dict(error))
-+ return
-
- log.debug("Received result for message %s: %s", msg_id, result)
- request_future.set_result(result)
-diff --git a/test/test_endpoint.py b/test/test_endpoint.py
-index 47a038b..b954732 100644
---- a/test/test_endpoint.py
-+++ b/test/test_endpoint.py
-@@ -115,9 +115,9 @@ def test_request_cancel(endpoint, consumer):
- 'params': {'id': MSG_ID}
- })
-
-- with pytest.raises(exceptions.JsonRpcException) as exc_info:
-+ with pytest.raises((exceptions.JsonRpcException, futures.CancelledError)) as exc_info:
- assert future.result(timeout=2)
-- assert exc_info.type == exceptions.JsonRpcRequestCancelled
-+ assert exc_info.type in (exceptions.JsonRpcRequestCancelled, futures.CancelledError)
-
-
- def test_consume_notification(endpoint, dispatcher):
-diff --git a/test/test_streams.py b/test/test_streams.py
-index 8c2e93e..480a73b 100644
---- a/test/test_streams.py
-+++ b/test/test_streams.py
-@@ -97,7 +97,8 @@ def test_writer(wfile, writer):
-
- def test_writer_bad_message(wfile, writer):
- # A datetime isn't serializable(or poorly serializable),
-- # ensure the write method doesn't throw
-+ # ensure the write method doesn't throw, but the result could be empty
-+ # or the correct datetime
- import datetime
- writer.write(datetime.datetime(
- year=2019,
-@@ -108,12 +109,10 @@ def test_writer_bad_message(wfile, writer):
- second=1,
- ))
-
-- if os.name == 'nt':
-- assert wfile.getvalue() == b''
-- else:
-- assert wfile.getvalue() == (
-- b'Content-Length: 10\r\n'
-- b'Content-Type: application/vscode-jsonrpc; charset=utf8\r\n'
-- b'\r\n'
-- b'1546304461'
-- )
-+ assert wfile.getvalue() in [
-+ b'',
-+ b'Content-Length: 10\r\n'
-+ b'Content-Type: application/vscode-jsonrpc; charset=utf8\r\n'
-+ b'\r\n'
-+ b'1546304461'
-+ ]
---
-2.26.2
-
diff --git a/dev-python/python-jsonrpc-server/files/python-jsonrpc-server-0.3.4-remove-pytest-cov-dep.patch b/dev-python/python-jsonrpc-server/files/python-jsonrpc-server-0.3.4-remove-pytest-cov-dep.patch
deleted file mode 100644
index a81919eae4bd..000000000000
--- a/dev-python/python-jsonrpc-server/files/python-jsonrpc-server-0.3.4-remove-pytest-cov-dep.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-pytest-cov is a deprecated dep
-diff --git a/setup.cfg b/setup.cfg
-index 03b63df..165c746 100644
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -13,9 +13,6 @@ exclude = test/plugins/.ropeproject,test/.ropeproject
-
- [tool:pytest]
- testpaths = test
--addopts =
-- --cov-report html --cov-report term --junitxml=pytest.xml
-- --cov pyls --cov test
-
- [egg_info]
- tag_build =