summaryrefslogtreecommitdiff
path: root/dev-python/python-keyutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-29 19:21:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-29 19:21:10 +0000
commit1bfb8c3d7e00e7ff828008510f5a7568c81d8889 (patch)
treea22ec1622549507f5333dca366a3b1f3e9af1dca /dev-python/python-keyutils
parent82020bf7ff936f52f6f1efc646ae374e46b5ed36 (diff)
gentoo auto-resync : 29:11:2022 - 19:21:10
Diffstat (limited to 'dev-python/python-keyutils')
-rw-r--r--dev-python/python-keyutils/Manifest1
-rw-r--r--dev-python/python-keyutils/python-keyutils-0.6-r1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-keyutils/Manifest b/dev-python/python-keyutils/Manifest
index 24ce5aab328f..58a4f8abb015 100644
--- a/dev-python/python-keyutils/Manifest
+++ b/dev-python/python-keyutils/Manifest
@@ -1,3 +1,4 @@
DIST python-keyutils-0.6.gh.tar.gz 45427 BLAKE2B b62a1194bad87fe42c658c0603ff236e8e5594e8d19dbf8b29bac5b2ef5b3c6a6d19eae3d529c9408e06802c883fad365d41d27c656776a4994b58a43b8bf1fc SHA512 e282d553a644d9b38c6256e027ee553a123bf21e4222491e22699ca5bc5041dedc4e9a9a8c1bafa44985f3b1d5fafd85ded9ed5332b6d94d6c62f3fa6bcb6d0d
+EBUILD python-keyutils-0.6-r1.ebuild 791 BLAKE2B 275e69c63650d675d94edccc64ffa30b5faf7672fe2f3bbd7f04f2d58b83439c0421b576e234a94174763511618f77ba6688042d7e2f5edbb2e0944c3ed7dc40 SHA512 8fdc98b6851b3da46c261236f19e7bbf58a059f04cb9f6de33310441b52a986998dabc8cb417beef28148d734a5984ae5edc76d08115d6d4826b86697ae46486
EBUILD python-keyutils-0.6.ebuild 713 BLAKE2B b478b7ecd924cbcc878d2a30fd452bba4f07591e1f294e164a08c450857df82987e419b6d1c509147f3a48bc8a59c51b84a1b1fa8b011c1d7da5f90058d010db SHA512 d935576540838a0c28168d3842e97d9ebac7246c56bf211f8472ad7ff99d2aa7a09854d1d16f9e4e5b45f5a488db4c0b2b160cbaf5fd7bd125f530bed9b985ff
MISC metadata.xml 383 BLAKE2B c88a0df9232a36db1f568579905d43c26fbdf5e2bd119e6ae9e7e4ff54f85bf7e247d57edaa6f9a364a938ccd6401f7e617515381f3fb4f9ad1f739f93d016ae SHA512 769de9462b430f810c33781b059d24da4d006b1e47ce1e57ca529a8a240442120fbe8b03c38f4e189e045593192b23cb0f4c5e0e1e63b4e43051da64129f63e4
diff --git a/dev-python/python-keyutils/python-keyutils-0.6-r1.ebuild b/dev-python/python-keyutils/python-keyutils-0.6-r1.ebuild
new file mode 100644
index 000000000000..a06efcf70a05
--- /dev/null
+++ b/dev-python/python-keyutils/python-keyutils-0.6-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="A set of python bindings for keyutils"
+HOMEPAGE="https://github.com/sassoftware/python-keyutils/"
+SRC_URI="https://github.com/sassoftware/python-keyutils/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+DEPEND="sys-apps/keyutils"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ default
+ sed -i -e '/pytest-runner/d' setup.py || die
+ rm keyutils/_keyutils.c || die
+}
+
+python_test() {
+ ln -s "${S}"/test "${BUILD_DIR}"/test || die
+ cd "${BUILD_DIR}" || die
+ distutils-r1_python_test
+}