summaryrefslogtreecommitdiff
path: root/dev-python/python-ldap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-python/python-ldap
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-python/python-ldap')
-rw-r--r--dev-python/python-ldap/Manifest4
-rw-r--r--dev-python/python-ldap/python-ldap-3.4.0.ebuild (renamed from dev-python/python-ldap/python-ldap-3.3.1.ebuild)10
2 files changed, 6 insertions, 8 deletions
diff --git a/dev-python/python-ldap/Manifest b/dev-python/python-ldap/Manifest
index f4e6fb2a6605..8e06df3f46cd 100644
--- a/dev-python/python-ldap/Manifest
+++ b/dev-python/python-ldap/Manifest
@@ -1,4 +1,4 @@
-DIST python-ldap-3.3.1.tar.gz 379810 BLAKE2B bb5d4902211b70cc57d2967134d3c41768bfedbec40be0d5bb592b96523f408952ca7e9a18546cc24f8267e958f454d56d97952092bc46e02bc9954bced9ba00 SHA512 2a1222bf5bbc1d885611fc4f2a25d0b1b64b49ae379f1212f1b3b70fc12fdc547eb6c4af4060a20bf082547b7df8f1824bb1fdfafa37ab21acf2f1e231c4d2d1
-EBUILD python-ldap-3.3.1.ebuild 2116 BLAKE2B 6c912f23d9da5a3fa7e41a111395e55b0c42935a38cc540872439e14166780665da086430c02ea95daefcb500066064983599d0f7e260c0c9ac4413474b0d81c SHA512 d54c7125ec65b8ce02706d3e9af3d1cd680ae919d180084a12f5c78eb6972967576a5db6396d3f61a2b0585b7c664875f92b3e0edd13a72dbb35651d874232a8
+DIST python-ldap-3.4.0.tar.gz 376169 BLAKE2B f514ddb6267fd8c21a1c4595669921a1256a8087a3a272b3751636313e7d79de9d34f4213aa57128679dc5a93db4ef7a71f7f92894a1802deb8c2ca9dfd92fe2 SHA512 d10c10f1d416a0f67e7669c6c0b5460a3484bc31f4af471d581a9207689e5687c08d1ad78ba8d47e0ce0c35d24d79e4b848b4c503534f211a36c1b882bee3605
+EBUILD python-ldap-3.4.0.ebuild 1980 BLAKE2B 5a8c768d30c16bfc24228963728e5762adb6d2aa6f9b2256678097df7bae2f7e432bf36656966fa06d06da9c344b83a221f9d2ed901c8799e373fabe36f367bf SHA512 a8e9b0d1df418dc9e32aa1c510103ff5f99df2f186d464810dfe2b1452667cb012bd98d6137cc97d8e41e5db6132239e32857ad03dc7615559daaf5d1ac2f4e2
EBUILD python-ldap-9999.ebuild 2121 BLAKE2B 41453d4bea20f0e62c78330f7f0c7c815471007c4b4f9f37796c4c88572d258067b27165664847dc84d7436a253c925af3948df461599b4bcdbfd67ed1b1b59b SHA512 4a1fe143cc02b90f29449929893a007714a164aa32e3e75c1df256c62d366825936a7593fde102a97c082bf16f4eaddc011f29829f2dad3672f5a733395ebd48
MISC metadata.xml 449 BLAKE2B 14ffa18ca09eb663d3ef4ff5bd0ebc8511fa408a4e96c93885ba2beaccdf3bb82a9733a01149e088c8b66d6cb938f94fc3940c0c0cca5685599191e772443cb6 SHA512 2f5c014e55f838b84abf6ba630b000620a01e2fca6d1f1bd1b30db309f820df50c2ef7feddc17c69ee0188c3cbc91a388933b4bccfc8d2ea0cb18c6dae85cda6
diff --git a/dev-python/python-ldap/python-ldap-3.3.1.ebuild b/dev-python/python-ldap/python-ldap-3.4.0.ebuild
index bd5fd8bb1e72..2121e5bb2ea7 100644
--- a/dev-python/python-ldap/python-ldap-3.3.1.ebuild
+++ b/dev-python/python-ldap/python-ldap-3.4.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( pypy3 python3_{7..10} )
inherit distutils-r1
@@ -18,12 +18,10 @@ else
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~x86-solaris"
fi
-LICENSE="PSF-2"
+LICENSE="MIT PSF-2"
SLOT="0"
IUSE="examples sasl ssl"
-# We do not need OpenSSL, it is never directly used:
-# https://github.com/python-ldap/python-ldap/issues/224
RDEPEND="
>=dev-python/pyasn1-0.3.7[${PYTHON_USEDEP}]
>=dev-python/pyasn1-modules-0.1.5[${PYTHON_USEDEP}]
@@ -58,7 +56,7 @@ python_prepare_all() {
python_test() {
# Run all tests which don't require slapd
- local ignored_tests=(
+ local EPYTEST_IGNORE=(
t_bind.py
t_cext.py
t_edit.py
@@ -70,7 +68,7 @@ python_test() {
t_slapdobject.py
)
pushd Tests >/dev/null || die
- epytest ${ignored_tests[@]/#/--ignore }
+ epytest
popd > /dev/null || die
}