summaryrefslogtreecommitdiff
path: root/dev-python/python-mpd2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-29 11:14:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-29 11:14:34 +0100
commitb83e82c4d46297f4fbe56dc8b6e149637d5d90fd (patch)
tree147ed0e44f1ffb8bfbb03c75e5a308d2138f3884 /dev-python/python-mpd2
parentdb970551c403ad46231ff09b63717be8c11351d3 (diff)
gentoo auto-resync : 29:04:2023 - 11:14:33
Diffstat (limited to 'dev-python/python-mpd2')
-rw-r--r--dev-python/python-mpd2/Manifest5
-rw-r--r--dev-python/python-mpd2/metadata.xml16
-rw-r--r--dev-python/python-mpd2/python-mpd2-3.0.5.ebuild51
-rw-r--r--dev-python/python-mpd2/python-mpd2-3.1.0.ebuild50
4 files changed, 122 insertions, 0 deletions
diff --git a/dev-python/python-mpd2/Manifest b/dev-python/python-mpd2/Manifest
new file mode 100644
index 000000000000..1a7f25785174
--- /dev/null
+++ b/dev-python/python-mpd2/Manifest
@@ -0,0 +1,5 @@
+DIST python-mpd2-3.0.5.gh.tar.gz 67224 BLAKE2B a0c78e3a2624247a7ed4228725dcc09457804636b01b09006bcd61800deefac8887fc9f76b9d7bb21c973e2dd9558e934f3864b2f8f5c041a94633a29f9a781e SHA512 521345b905113eaa56e6ec983e4d968d77dca30f839ab52a00e146f311269828ed383bce460ba1daf61b7f98c63ae3b7a3cbcb55cf917b1c5a5a11cf62b6a7d5
+DIST python-mpd2-3.1.0.gh.tar.gz 69162 BLAKE2B fb9b13f3e73b654d7e2a6ee84907f84ebf354d8f56ee47f58046a28aef1d43b5ddd52bf51f42a3e56dd6d8036010abc74d5537cfe8cf4f976b0a758506879dfe SHA512 9d8dd774540d9e09804fd293ce362401b2253f8021c1581c0764bac0b61d2e4b5f50bb752e5d774459194a717354f28ad5d96d48f29ef0f54011969ec91ff106
+EBUILD python-mpd2-3.0.5.ebuild 1001 BLAKE2B eabd6c995cbaaf9c8a2baa0d73058d20794485a7a2e4240dddb7578774ca3c42cd285c89adea58a3f94460b67eb15e6f15d2ddecc6650b85a34b012654473208 SHA512 ffdf2e017255fe428c66711556b9425e6e0deb2f05195c257e05757bd3ce09676a9c994068bdf146c7da965ec91547ec7de10854cb14ef545b2806c05bcbb03a
+EBUILD python-mpd2-3.1.0.ebuild 1005 BLAKE2B 578f6bc5ff508b83ca0db9da36c6030654e5c82f61932274a857f76a8d8ad0efcbe19d12ad286ebc2e122909660b64e9ec0dfaffdf99333383a1e786129e11d4 SHA512 e69b4c8a3ec610fa4a3c2adedb9123f3a1aa54508021b9266eb90ca973d45b2d75f8a8776be6d4c3c2e1326e85257e3adee88facc6d94b48e7e9d774e9ee9c21
+MISC metadata.xml 464 BLAKE2B d64863a0d0de7bdbb309ea89cf3758d7347ccfb29fd810e3cc99735b6cb096b1dc21857905f04f689865690c170bcc141b2ecc7ac0954f5db748fae52e8754ba SHA512 a37f69491be26d10e30ffedf86582ee8f0cccec30278f2edf24b9018357609ff2b65a68b3e778aa5cd956f16ecb75e490be3305ea1d8e2ded3d1a3d187f644ae
diff --git a/dev-python/python-mpd2/metadata.xml b/dev-python/python-mpd2/metadata.xml
new file mode 100644
index 000000000000..ea0f1ffd8944
--- /dev/null
+++ b/dev-python/python-mpd2/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">python-mpd2</remote-id>
+ <remote-id type="github">Mic92/python-mpd2</remote-id>
+ </upstream>
+ <use>
+ <flag name="twisted">Enable twisted support</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-python/python-mpd2/python-mpd2-3.0.5.ebuild b/dev-python/python-mpd2/python-mpd2-3.0.5.ebuild
new file mode 100644
index 000000000000..1b8aa7be2faf
--- /dev/null
+++ b/dev-python/python-mpd2/python-mpd2-3.0.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=python-mpd2-${PV}
+DESCRIPTION="Python MPD client library"
+HOMEPAGE="
+ https://github.com/Mic92/python-mpd2/
+ https://pypi.org/project/python-mpd2/
+"
+SRC_URI="
+ https://github.com/Mic92/python-mpd2/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-3+"
+KEYWORDS="amd64 ppc ppc64 x86"
+SLOT="0"
+IUSE="examples +twisted"
+
+RDEPEND="
+ twisted? ( dev-python/twisted[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst doc/{changes.rst,commands_header.txt} doc/topics/. )
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ epytest mpd/tests.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples/.
+}
diff --git a/dev-python/python-mpd2/python-mpd2-3.1.0.ebuild b/dev-python/python-mpd2/python-mpd2-3.1.0.ebuild
new file mode 100644
index 000000000000..a3d2930f7379
--- /dev/null
+++ b/dev-python/python-mpd2/python-mpd2-3.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python MPD client library"
+HOMEPAGE="
+ https://github.com/Mic92/python-mpd2/
+ https://pypi.org/project/python-mpd2/
+"
+# as of 3.1.0, sdist is missing some doc files
+SRC_URI="
+ https://github.com/Mic92/python-mpd2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="examples +twisted"
+
+RDEPEND="
+ twisted? ( dev-python/twisted[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst doc/{changes.rst,commands_header.txt} doc/topics/. )
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ epytest mpd/tests.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples/.
+}