summaryrefslogtreecommitdiff
path: root/dev-python/python-mpd2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-14 07:13:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-14 07:13:52 +0000
commitfe1e3bbca60a6b4b9a1889f5252e02c27b459f63 (patch)
tree2ee0c8c664dc7593daf17a1bfac31e1dd4e5c6f5 /dev-python/python-mpd2
parent94eb99943eafb48140b436b347abaaee77209c01 (diff)
gentoo auto-resync : 14:01:2024 - 07:13:52
Diffstat (limited to 'dev-python/python-mpd2')
-rw-r--r--dev-python/python-mpd2/Manifest2
-rw-r--r--dev-python/python-mpd2/python-mpd2-3.1.1.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/python-mpd2/Manifest b/dev-python/python-mpd2/Manifest
index dd43416a9630..f092dcf564ca 100644
--- a/dev-python/python-mpd2/Manifest
+++ b/dev-python/python-mpd2/Manifest
@@ -1,3 +1,5 @@
DIST python-mpd2-3.1.0.gh.tar.gz 69162 BLAKE2B fb9b13f3e73b654d7e2a6ee84907f84ebf354d8f56ee47f58046a28aef1d43b5ddd52bf51f42a3e56dd6d8036010abc74d5537cfe8cf4f976b0a758506879dfe SHA512 9d8dd774540d9e09804fd293ce362401b2253f8021c1581c0764bac0b61d2e4b5f50bb752e5d774459194a717354f28ad5d96d48f29ef0f54011969ec91ff106
+DIST python-mpd2-3.1.1.gh.tar.gz 69613 BLAKE2B 4769799edb7a5fa8d772e95fdda362845d97ff2e17bc5eed7ec057c0e17389e8ad3b5d1ecd3b169ddea9d33fdfc52d46b86b8e1abc89489cf04f53aa803219d0 SHA512 abd882bc0652ed4a8ee2f4abf0a039e7c62e77b35d278c5fc99bb032c220caac831cc483445516044964f2ea078d2134af61c64d55cb20770b4d32a5aa1ce5e2
EBUILD python-mpd2-3.1.0.ebuild 1030 BLAKE2B 37d26cd65c0131c61937abebca8665371ad9ae6494f936d1009c018e1712874367cd9497e9febae80ebf254827b8e1852d07b0bf3849200c86a6a2c9d5e02c94 SHA512 da989add0e672ea2772704ea8847446a5a0f89861e7c6b137bb916eb242f1ebbdabc762c08187fde61a692cea888fed0504bde18001127844b96d2df09b636fc
+EBUILD python-mpd2-3.1.1.ebuild 978 BLAKE2B 3432b26939dd796f7f7e370ac72e3babb5a5ef08c63dae9586f322663fcabeccd45611359c3dbb47958167679c98b2fa8b88ed181b0f4b40fb53fe20aa46a4fe SHA512 1425d58dc652b38810b31f44132f30f4151afafb545cd9f70654a9e127678f19a23d338fca220972fbd79990ba51748fa3fbf28c9bb5ccec8ce34c148ec4f012
MISC metadata.xml 464 BLAKE2B d64863a0d0de7bdbb309ea89cf3758d7347ccfb29fd810e3cc99735b6cb096b1dc21857905f04f689865690c170bcc141b2ecc7ac0954f5db748fae52e8754ba SHA512 a37f69491be26d10e30ffedf86582ee8f0cccec30278f2edf24b9018357609ff2b65a68b3e778aa5cd956f16ecb75e490be3305ea1d8e2ded3d1a3d187f644ae
diff --git a/dev-python/python-mpd2/python-mpd2-3.1.1.ebuild b/dev-python/python-mpd2/python-mpd2-3.1.1.ebuild
new file mode 100644
index 000000000000..91c77bfc32d1
--- /dev/null
+++ b/dev-python/python-mpd2/python-mpd2-3.1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python MPD client library"
+HOMEPAGE="
+ https://github.com/Mic92/python-mpd2/
+ https://pypi.org/project/python-mpd2/
+"
+# as of 3.1.0, sdist is missing some doc files
+SRC_URI="
+ https://github.com/Mic92/python-mpd2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3+"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="examples +twisted"
+
+RDEPEND="
+ twisted? ( dev-python/twisted[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ dev-python/twisted[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst doc/{changes.rst,commands_header.txt} doc/topics/. )
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest mpd.tests
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use examples && dodoc -r examples/.
+}