summaryrefslogtreecommitdiff
path: root/dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild')
-rw-r--r--dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild b/dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild
new file mode 100644
index 000000000000..11ca6622f42e
--- /dev/null
+++ b/dev-python/python-poppler-qt5/python-poppler-qt5-21.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=sip
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing qmake-utils
+
+DESCRIPTION="Python binding for libpoppler-qt5"
+HOMEPAGE="https://github.com/frescobaldi/python-poppler-qt5"
+SRC_URI="https://github.com/frescobaldi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/poppler[qt5]
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ DISTUTILS_ARGS=(
+ --jobs="$(makeopts_jobs)"
+ --qmake="$(qt5_get_bindir)"/qmake
+ --qmake-setting="$(qt5_get_qmake_args)"
+ --verbose
+ )
+}