summaryrefslogtreecommitdiff
path: root/dev-python/python-recaptcha
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
commitc5283d322accc6097afec74eab24550829788bab (patch)
treeb99ce668128d82a026eaa31461643f9173f9b77b /dev-python/python-recaptcha
parent5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (diff)
gentoo resync : 23.03.2018
Diffstat (limited to 'dev-python/python-recaptcha')
-rw-r--r--dev-python/python-recaptcha/Manifest3
-rw-r--r--dev-python/python-recaptcha/metadata.xml14
-rw-r--r--dev-python/python-recaptcha/python-recaptcha-2.0.0.ebuild27
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/python-recaptcha/Manifest b/dev-python/python-recaptcha/Manifest
new file mode 100644
index 000000000000..80c791b42e88
--- /dev/null
+++ b/dev-python/python-recaptcha/Manifest
@@ -0,0 +1,3 @@
+DIST python-recaptcha-2.0.0.tar.gz 5556 BLAKE2B b752915eb95343d7cbce483f49ce9d93ecf837c85a1615e414e14226c54dc60ede3187bd127e09769106a7eb06156ab2b73b0a3839743c29b6aba6e6c4d96951 SHA512 3a60062f36833888a110d5979ca7a7f46cef927bfcf427aba72d2f6a99a9c401b20bea997ff8fb2b8435876bed3880371a84568b95da1341940d275cba8ff178
+EBUILD python-recaptcha-2.0.0.ebuild 771 BLAKE2B 5889d47423245f88faa125e5d0983210b6023357c74476b19ff340a5f572e64172e1b184be9eb0e0f9e41cca817462c5f829c7fd30cdce0c8e4c779d05771a87 SHA512 c4bcecacfb9d341e0e6bb9c56ef7628fdb874e2683bbe431bdecdabb990d91fdb9a3c0015f947c4ea1f89eb3fd9162a1a0b63cef749ef4fc211441d4fbf5472f
+MISC metadata.xml 427 BLAKE2B ba42439a7701580eec32dbadf9a62d7bc8ffbb966d8e997724ff6bd72c366c3db7e2b92a966a7b88a4d2c5f28773c26fecdd6842003682d408c1833bf80795e6 SHA512 7bebdf6b10791c257952c29c3eba4c6886ed240823c14190c5652fbefefa847e25d1ade70e0d611011da9a627459cd5aaca81d6dd0ee57fa848146c3fbac0dcf
diff --git a/dev-python/python-recaptcha/metadata.xml b/dev-python/python-recaptcha/metadata.xml
new file mode 100644
index 000000000000..97e2d6ed858e
--- /dev/null
+++ b/dev-python/python-recaptcha/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hanno@gentoo.org</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">redhat-infosec/python-recaptcha</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-recaptcha/python-recaptcha-2.0.0.ebuild b/dev-python/python-recaptcha/python-recaptcha-2.0.0.ebuild
new file mode 100644
index 000000000000..e77a89547183
--- /dev/null
+++ b/dev-python/python-recaptcha/python-recaptcha-2.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A plugin for reCAPTCHA and reCAPTCHA Mailhide"
+HOMEPAGE="https://github.com/redhat-infosec/python-recaptcha"
+SRC_URI="https://github.com/redhat-infosec/python-recaptcha/releases/download/v${PV}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ !dev-python/recaptcha-client"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install() {
+ distutils-r1_python_install
+ # otherwise we have an empty recaptcha dir/namespace
+ touch "${D}$(python_get_sitedir)"/recaptcha/__init__.py
+}