summaryrefslogtreecommitdiff
path: root/dev-python/python-redmine
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/python-redmine
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/python-redmine')
-rw-r--r--dev-python/python-redmine/Manifest2
-rw-r--r--dev-python/python-redmine/python-redmine-2.0.2.ebuild17
2 files changed, 3 insertions, 16 deletions
diff --git a/dev-python/python-redmine/Manifest b/dev-python/python-redmine/Manifest
index 180bf26cba05..a2a211531a5e 100644
--- a/dev-python/python-redmine/Manifest
+++ b/dev-python/python-redmine/Manifest
@@ -1,3 +1,3 @@
DIST python-redmine-2.0.2.tar.gz 559017 BLAKE2B 3bec44ec562f524f7f9b4903e51c1ecaf1f9c7d76e7bbdcd6edd95e7477e9038011336514ea5f75ec23880469331ec5a8b5417d44d032d7440234db1e7bf59ca SHA512 3f8e11315e8e2b4474e8b981bd801ef75857fe73e8ed18d27f64223703d18ea2061416ed38ea35c4a4460a4ccba167b41ab48e2489930181951e9e2a5f53ec12
-EBUILD python-redmine-2.0.2.ebuild 1270 BLAKE2B 01b09083a8735c44a8dfcc90a8da5ca9b7f06d004d81781c0646d1416c7e9d72ab6357615547a926197bf669c518baba12cf98538813d764bf27c82e09960849 SHA512 c68c0b57dbcd379eb0a2bf9af916695c212fe8861baa26f34c743d93d28886042ee1d30c59c66a4c73f1396b393d6a155c7ca01d7c15e25e9801fb2e90eab6b0
+EBUILD python-redmine-2.0.2.ebuild 906 BLAKE2B 063868e8683617a2acab0575cf9bfabc26e691f4f7cff9a863264d6fc6ab5f86f34caacb7de3c44e84acfb9691412daa01d26a418f8ed89e203a2376e5c7e300 SHA512 ae0f7b365f4b4eb972081b0e0c99dc19fa5be28ef105d2a3ffdc2a45a1ebbf4d11567236a0171a7d5150acce758777fdf11d7aa37ff45dc39348ca8b1f33d3ae
MISC metadata.xml 400 BLAKE2B 03f628bb2d3dc4fe61613c08dff75e0534c475d637150a9c895e23e613b5c32188f78b298fb1b754d0df6e617f5d7c28e5e20f1984fe297a6d550b2debfe290b SHA512 12d43f2ec4712a7c01ed86aa2b1d05eebb907a8a6bd787ec82aff8ea2a97cc6708255dfad3d386550bcc72887d1b273b6ff3f958bc22e5bbdc4bd8a8d28a57ac
diff --git a/dev-python/python-redmine/python-redmine-2.0.2.ebuild b/dev-python/python-redmine/python-redmine-2.0.2.ebuild
index 004a759abd1c..403396ebdefe 100644
--- a/dev-python/python-redmine/python-redmine-2.0.2.ebuild
+++ b/dev-python/python-redmine/python-redmine-2.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -14,19 +14,10 @@ SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
-# This package bundles dev-python/requests, so setup.py won't check for
-# it. As a result, we don't need RDEPEND in DEPEND unconditionally.
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
+distutils_enable_tests nose
python_prepare_all() {
# Remove the bundled copy of dev-python/requests...
@@ -40,7 +31,3 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-
-python_test() {
- nosetests || die "tests failed under ${EPYTHON}"
-}