summaryrefslogtreecommitdiff
path: root/dev-python/python-rtmidi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-25 19:30:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-25 19:30:41 +0000
commit026061ba423025e6713112920f290759cdee03c4 (patch)
tree0e557363849e4d5c1320820fcf175bc1ec9690ab /dev-python/python-rtmidi
parent479921825a5c44a5fbcd5441f00ee98e54db9bac (diff)
gentoo auto-resync : 25:12:2023 - 19:30:41
Diffstat (limited to 'dev-python/python-rtmidi')
-rw-r--r--dev-python/python-rtmidi/Manifest2
-rw-r--r--dev-python/python-rtmidi/python-rtmidi-1.5.8.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/python-rtmidi/Manifest b/dev-python/python-rtmidi/Manifest
index 59c03a1504a7..30cee191132d 100644
--- a/dev-python/python-rtmidi/Manifest
+++ b/dev-python/python-rtmidi/Manifest
@@ -1,4 +1,6 @@
AUX python-rtmidi-1.5.1-unbundle_rtmidi.patch 1455 BLAKE2B 2cc76ace5758131a069194e9d30c8288ed93a261d41a2b4cf0294e2b4fc7ebee9e0c43b4377143ae8074a03dcc2abf13fd85fdebeebd321efce00e25e43057b1 SHA512 92c11d878018ded30dffa0d06006f8471054321af8d9f58268d4d899121dac66712ddc3a53285c19293fb2d52d4d054b0d803c559e9c01cb8c8f161ce5f2c734
DIST python_rtmidi-1.5.7.tar.gz 368514 BLAKE2B 32028dff34928b1794cc178b22821fe8e01bff36d18b17b8673c763b21ca7ef85a6cb3ee62adcddbaf0b655079e7b8819ba5a28e58b8d5713015728cd6648246 SHA512 23c88cd307b5bc937920db9b39d0423043fb47878d679f4d721a025368a01e23b8e72749e1146da3277d37a20a9c5486e2c40c2a907c5efc5418567e97c3de91
+DIST python_rtmidi-1.5.8.tar.gz 368130 BLAKE2B 99fecb8cd003431b5fca31f436a77f27a50076a02ea7f92019800d0816c968f032bd31d236a13d67b2ee9ebdc341d16955675867a8dd345e76282131b781ef13 SHA512 0f2b949a2a53f813a891bc391ce0369fbbec0d6e898a9ace2925adc5714d791ce1f4df133edf34c87b3336cb3ab4ad70851a42124241ec1707f32f66a778dc18
EBUILD python-rtmidi-1.5.7.ebuild 1559 BLAKE2B fcbddc44d5a6624303b4c6f06de5704215b9a79b6fe7a94d46e336f9c0faecaea59ba6a91a4e64ce4899d28a5f0f42d36e516436134a894a2c15557947d8b2c0 SHA512 d41c941fdc13381c022565b82c64100805698db6aada3cd20011482b36a7c755294ee160cb55df01db9f274f2cf38e92ebd6cff653826bb22cc6f92e8d97a520
+EBUILD python-rtmidi-1.5.8.ebuild 1559 BLAKE2B fcbddc44d5a6624303b4c6f06de5704215b9a79b6fe7a94d46e336f9c0faecaea59ba6a91a4e64ce4899d28a5f0f42d36e516436134a894a2c15557947d8b2c0 SHA512 d41c941fdc13381c022565b82c64100805698db6aada3cd20011482b36a7c755294ee160cb55df01db9f274f2cf38e92ebd6cff653826bb22cc6f92e8d97a520
MISC metadata.xml 388 BLAKE2B b1bce0f609aae5a298c26c80c3dc3aa33eadf32c9de9da22f4a4f808d1cfd8c769b095d12f2264cf9dd04cdbec8a0fb7202b10c04bb43f9112146023aadd398d SHA512 012ad743d364b9266bef852d159235f27b172ec7fceff43737fe8a67478f991dc53532b021c02d8ffc2eea19cdc568046cf90e440afefb46dcdad275a33f71e3
diff --git a/dev-python/python-rtmidi/python-rtmidi-1.5.8.ebuild b/dev-python/python-rtmidi/python-rtmidi-1.5.8.ebuild
new file mode 100644
index 000000000000..a1779b717ea1
--- /dev/null
+++ b/dev-python/python-rtmidi/python-rtmidi-1.5.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DOCS_BUILDER="sphinx"
+DOCS_DEPEND="dev-python/myst-parser"
+DOCS_DIR="docs"
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=meson-python
+
+inherit distutils-r1 docs pypi
+
+DESCRIPTION="Python bindings for media-libs/rtmidi implemented using Cython"
+HOMEPAGE="
+ https://pypi.org/project/python-rtmidi/
+ https://spotlightkid.github.io/python-rtmidi/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+alsa jack"
+
+# Most of these tests do not play nicely with the sandbox, some only
+# work with exactly the same version of rtmidi as the bundled one, and
+# several fail even with disabled sandbox unless there are actual MIDI
+# I/O devices present.
+RESTRICT="test"
+
+DEPEND="media-libs/rtmidi[alsa?,jack?]"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.1-unbundle_rtmidi.patch
+)
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # Just in case
+ rm -r src/rtmidi || die
+ rm src/_rtmidi.cpp || die
+
+ # Needed by USE=doc because documentation generation happens in ${S}
+ # but the version.py generated by Meson end up in respective ${BUILD_DIR}s.
+ # The version put in ${S} should be ignored by everything except Sphinx but
+ # just in case, be consistent and generate it unconditionally.
+ sed -e "s|@VERSION@|${PV}|" < rtmidi/version.py.in > rtmidi/version.py || die
+}
+
+python_test() {
+ cd "${T}" || die
+ eunittest "${S}"/tests
+}