summaryrefslogtreecommitdiff
path: root/dev-python/python-sense-hat
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /dev-python/python-sense-hat
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'dev-python/python-sense-hat')
-rw-r--r--dev-python/python-sense-hat/Manifest4
-rw-r--r--dev-python/python-sense-hat/metadata.xml9
-rw-r--r--dev-python/python-sense-hat/python-sense-hat-2.2.0-r1.ebuild (renamed from dev-python/python-sense-hat/python-sense-hat-2.2.0.ebuild)16
3 files changed, 20 insertions, 9 deletions
diff --git a/dev-python/python-sense-hat/Manifest b/dev-python/python-sense-hat/Manifest
index 904c3cbbd67e..eb63434ad11f 100644
--- a/dev-python/python-sense-hat/Manifest
+++ b/dev-python/python-sense-hat/Manifest
@@ -1,3 +1,3 @@
DIST python-sense-hat-2.2.0.tar.gz 20841 BLAKE2B 59e6b9111fb90493e6bda00ce4a4c143dcb84d8b6529efadaf2f337adb38a8fb4287cbd9a303070ea4f335f1e03c6f4789e6f8fbe64a7c70db20675bdae7c6a1 SHA512 71914f6f22206cff23992a6908698978741a46bf9b98648388bac4550f39e8de73db6bd389b79585eba6e82160649a8c8da4217d515bbdbcb50d47218415f3ac
-EBUILD python-sense-hat-2.2.0.ebuild 618 BLAKE2B 3cc52722c66c5ed62de0dfe579bcba3091c5aeab55874c2d0fceec99b6842526b7befc44daedf689feb6c2b3df70e9d47a4a522cafad031e2961b06b7885cfee SHA512 b7e214bf47fc6650732acf95a7681f994bc5efc39e87703d7f3bcad0058d9b5c639191c9ba7f8667465e86595b7341c89ce9b62870184114e366afb1f1cb0b8b
-MISC metadata.xml 369 BLAKE2B 99bc89ce5469bce6e867ce73fa66fee3fa41bf2166453c3606b03b1f3879f837c46d41068430e217a7ab4b0d0096650762095ffe5f13382ab055e5815f90ebb1 SHA512 5d49b66d13a6055421fc9e9a180d6d5657e367cfdc6e74a13c16955cc1bfda765605f0ab7c0d7d5f67ce847e09306fef52a2fb621eccdf358e5d21e82129a2b3
+EBUILD python-sense-hat-2.2.0-r1.ebuild 630 BLAKE2B b3eb4640b05999afe28c7dbd3734cb6e78e1ae4248e91f72ed9b88bc463b37604c493c1f2b7855009bd71ee38bba3e8ebee8d52f3d5cdfd30b8f75cf8bc8beed SHA512 c1eb21667f27205b60ef569f36e3c930f2e5c6bbd9b4980669881995536acd3a75fb550bbf53725bac1a2f7a0cc531e90836d1063d9aab474e2655a19e407c8c
+MISC metadata.xml 771 BLAKE2B 05de535f0e56d7233bc94020ee828866757b95725e8f9f3cbd7681ca7ff6b92000dd8176af44115ebfae157886ec305513ec6f1f12cc56a233ff3fdc73e63fb6 SHA512 e4c3cb494bb4c8b874be22478577f0ee6a4f3f6c12a8eb00e27d6a854d5c88265714ee438486663e315c36c84369c67785ebc38764617644cda0bd6bfd314cfa
diff --git a/dev-python/python-sense-hat/metadata.xml b/dev-python/python-sense-hat/metadata.xml
index 54d5423c4060..eb43e658b304 100644
--- a/dev-python/python-sense-hat/metadata.xml
+++ b/dev-python/python-sense-hat/metadata.xml
@@ -9,4 +9,13 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <longdescription>
+ Python module to control the Raspberry Pi Sense HAT used in the Astro Pi mission.
+ An education outreach programme for UK schools sending code experiments
+ to the International Space Station.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/RPi-Distro/python-sense-hat/issues</bugs-to>
+ <remote-id type="github">RPi-Distro/python-sense-hat</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/python-sense-hat/python-sense-hat-2.2.0.ebuild b/dev-python/python-sense-hat/python-sense-hat-2.2.0-r1.ebuild
index e941ad6c7acc..fed87a383669 100644
--- a/dev-python/python-sense-hat/python-sense-hat-2.2.0.ebuild
+++ b/dev-python/python-sense-hat/python-sense-hat-2.2.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="7"
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
inherit distutils-r1
@@ -15,9 +15,11 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~arm ~arm64"
-RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/rtimulib[${PYTHON_USEDEP}]"
+ dev-python/rtimulib[${PYTHON_USEDEP}]
+"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${RDEPEND}"
+DEPEND="${RDEPEND}"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"