summaryrefslogtreecommitdiff
path: root/dev-python/python-slugify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-19 13:00:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-19 13:00:31 +0000
commit26f79803004cb53e92cf2f0e889de89979385aa9 (patch)
treed46d17cb971a2dffbe96669e4ad8d341eb5ee3c7 /dev-python/python-slugify
parentc5572b13d51970d6603acd131f27991cc1b66a79 (diff)
gentoo auto-resync : 19:11:2022 - 13:00:31
Diffstat (limited to 'dev-python/python-slugify')
-rw-r--r--dev-python/python-slugify/Manifest2
-rw-r--r--dev-python/python-slugify/python-slugify-7.0.0.ebuild29
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-slugify/Manifest b/dev-python/python-slugify/Manifest
index bd39641877fc..865c543da16f 100644
--- a/dev-python/python-slugify/Manifest
+++ b/dev-python/python-slugify/Manifest
@@ -1,3 +1,5 @@
DIST python-slugify-6.1.2.tar.gz 13302 BLAKE2B 600ac1cc37cd0001ca3c08cdccb4655dd3754f7673596eada2dfb6adcb6c190f0e5644bd1cba4debf0fae42ae183b3d81acdcc09270e3ade94076d69ba25895a SHA512 3748c18d469032fc002318fbd5730b96a6f8430ff7b0b1a9afb4c19d4dd8e7528400682fa6b2fcc11ec4230917d7e7f61de290f5b199935d77d5335006af0ffb
+DIST python-slugify-7.0.0.gh.tar.gz 13257 BLAKE2B 6d50fd25ac89caed3a970f4cce786d9b61de68386fc183659c0d884877edc934e121ad07316259af08deb61a30ac33f0076a90b2d5a650dfb113e6b6416addfe SHA512 c22743a28ffb273546541eaf59d2a7beb9070a7f81e504acaf73d220c2be83a87d02012b5841076539ba6bae5778dd47309ee7ceef9f8479c993dda6b3e09837
EBUILD python-slugify-6.1.2.ebuild 594 BLAKE2B 380f92dec445d336032dfef1275603db24ee4db779c8e1cbbe25df03d0ac6a81a26f02819147e01b80fc13624919d147b40b8c800424da89b79780a366484535 SHA512 d84326a73774731dfabe4c63604444bd3a21441ca7fe5ee932546f89ac19161f1bd5d372cf1d0291636aec26fbd03942ef56da32fdd38a80c5d0c82a72b2071a
+EBUILD python-slugify-7.0.0.ebuild 601 BLAKE2B 274201fc7a7ea4f6cc141fbb663e5239809690ba40c73576f4e49ec85007825a78a4adbe0880c6f8f4902448e2bc94254e95046a573decf737eb07b5c92ead1c SHA512 651019a1d7210c9231c034c37b5e5306fd7d3bf20a12c57d3f1c93c57d39c07a711478f5d2471c79715977f10c9ab30825d301b0c529faee627c95fb59648358
MISC metadata.xml 637 BLAKE2B 4869f272370af0065e6d0479d660a8fba6665ad019a3072cb3a2f1b003fa0cd7ae57dc8e19ad8ceda33d97355c1e4d1ebebb96978935d016fa8bcd2b7fd72660 SHA512 bc09a7914759371c03436e5dd0ef50bc1972cfbf2b815e91048d78d277402d8431be59673f4106483b690dfe3b3cde7ca5e39719effc23dc77e1e9b505e14a01
diff --git a/dev-python/python-slugify/python-slugify-7.0.0.ebuild b/dev-python/python-slugify/python-slugify-7.0.0.ebuild
new file mode 100644
index 000000000000..a12154fd4646
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-7.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="
+ https://github.com/un33k/python-slugify/
+ https://pypi.org/project/python-slugify/
+"
+SRC_URI="
+ https://github.com/un33k/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/text-unidecode[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest