summaryrefslogtreecommitdiff
path: root/dev-python/python-stdnum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-18 06:49:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-18 06:49:50 +0000
commit529bbf6d047ac6b80c0d9310ec0f666c145ec5fe (patch)
treeae415fb3fee6b16f7371a5d3597dcf98cca19b62 /dev-python/python-stdnum
parentec33f4bcbd3944dc39c56a98cde12232684932cf (diff)
gentoo auto-resync : 18:03:2024 - 06:49:50
Diffstat (limited to 'dev-python/python-stdnum')
-rw-r--r--dev-python/python-stdnum/Manifest2
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.20.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/Manifest b/dev-python/python-stdnum/Manifest
index 011945ea099a..343bb90732d8 100644
--- a/dev-python/python-stdnum/Manifest
+++ b/dev-python/python-stdnum/Manifest
@@ -1,3 +1,5 @@
DIST python-stdnum-1.19.tar.gz 1134517 BLAKE2B a6e35abcd00302dff0c6df82c13691c4528de069b7702f905aabffd840b7d95902f2c74525d824606bc4b28579d38153367997a73910ab93afb4eb4272b76c40 SHA512 02c56aea710a9a02e14160840fbd45751cd00f1a49b1d046124945ba92e2dd3377006f44a146030522d09b92f809ceb4d1e3589ef3d9c9302f7674a79602ef07
+DIST python-stdnum-1.20.tar.gz 1191978 BLAKE2B 8395106d155c1f4642a74691d219230b42e81b521db41c57d5e978eb8e1769ca51598a1ad061356a1997fac5a60ca21796d1e8f79fa7d737e70fbbfe78dbfcc6 SHA512 92ec9fcb3bf71405569e93668ab1d089225da74a33095e63ee8f0116c868a4b937d093ba98e29085889d1745cc55eab13936d6ed9ceb24beecbc193c722a515e
EBUILD python-stdnum-1.19.ebuild 741 BLAKE2B 7df875ef753dd80cbd2055dd6fa6d57b93022f2f988b4ad60397cd3336110d14774faa8f2bff4112c8225236b114a967595e4b1ddfd07e3ca405271bdefac31a SHA512 fb025c24dca224c47a726e1e061163435e4bc76139600e8266a6cfd15d61072e221a143d08a196be2f1cbb99b8529fcad850693241eaff144836d609007d3de4
+EBUILD python-stdnum-1.20.ebuild 744 BLAKE2B da29658dcf1e0a8c86a84f40a8e0281f1edf90e6cb656510354066e3610d0bb970a7d02b91c9db1cafd83e903e07a0fdec8f5de1a883922236fdf82321d70bce SHA512 5477d36c37b6d4e3560f0fda9aaf914edf9e29408599c7bb6433c5ac1d77b8b1b53d0a613629e87b06a9e69b6df3d640bf43f8bb99af97ff89f820c6586ddc96
MISC metadata.xml 461 BLAKE2B ca459eeb4a49d155ee0e1f53a3830f500607e7b412c9546c05e54c99fb2d74982e4bb3815fb5373b627d09c580f3f6807737b33022542f0fb13ed45c085e57e1 SHA512 66ebd3c6792e7bc35df1b77171179191a98c476c38827fb11cfff1e0c003317a2eb296ae12cea484bdcfbfd364dfafb0abc60cf0886c993b66860f7d9efe6013
diff --git a/dev-python/python-stdnum/python-stdnum-1.20.ebuild b/dev-python/python-stdnum/python-stdnum-1.20.ebuild
new file mode 100644
index 000000000000..9ca2716b7fa7
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.20.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="
+ https://arthurdejong.org/python-stdnum/
+ https://github.com/arthurdejong/python-stdnum/
+ https://pypi.org/project/python-stdnum/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="vies"
+
+RDEPEND="
+ vies? (
+ || (
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/suds-community[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov.*::' setup.cfg || die
+ distutils-r1_src_prepare
+}