summaryrefslogtreecommitdiff
path: root/dev-python/python-stdnum
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-python/python-stdnum
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-python/python-stdnum')
-rw-r--r--dev-python/python-stdnum/Manifest2
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.17.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/Manifest b/dev-python/python-stdnum/Manifest
index a7d267c59151..369a44dc5781 100644
--- a/dev-python/python-stdnum/Manifest
+++ b/dev-python/python-stdnum/Manifest
@@ -1,3 +1,5 @@
DIST python-stdnum-1.16.tar.gz 1039599 BLAKE2B 98197fca412371757b7e7ec242d30d5fc43352b9eba7677aeb3a475dbe7a379c4f88797192b8e5de97493186562d1d21347703643be7798316e22f28c6a144bf SHA512 29ad92a8d1d3267c56e3d128700611cbfe3bc7a27a1420bfe62851f110f3f23b1d8927771588ef043aba366913bf7a5b0eb72896ee50343f3adf72cdb071415b
+DIST python-stdnum-1.17.tar.gz 1068804 BLAKE2B eaef8d0016f7e836226a6d83d4b54d507477d333af8572f59f24eba44f3a24bedc4d0b7d3492e7a5a64d9ceff77e296bda2876f976aab46cdb27989d0dd80df3 SHA512 9ddec525ea153e3066f205ee70602a59821e793f9ffde66a4b01511daf9a559a3a42082a99bddf69c1159a27b2d9e64d91f8a65ee283a2d7da473d766ce0e711
EBUILD python-stdnum-1.16.ebuild 567 BLAKE2B 46fcc7014aa6fe5b8086e6cb4259de1af50f731cce5cf12c030d24214f424c763ae57a7321bee61e27c85c859404a61c0740af248828001d21f75627b8cc6a7b SHA512 9b2035fcaa3d1d4b72fa1cfca5ee1f2513f054c201dbc4aa221403cf6513670fe46fcddfddad89aaf557be9bbf2f679bb0b7f5180c4d1e06759379e0c1df95aa
+EBUILD python-stdnum-1.17.ebuild 630 BLAKE2B 4f28f56637774bf01acbd3e5f8e2130faca034edcafef3371536232725dbd1edd592a74aeb6eeee48971b87394011278fdd9ca125835d4686c35c458f6aeba2e SHA512 8b9cd0d863cba06523c65445c1a9335a3952584cc25c1069be6b92db2ec5467fa656b2c9b101410aba8972b834dac47808937623ae0c3e9f8fba22ad90d009f2
MISC metadata.xml 395 BLAKE2B cc5c1669f2d1ea70021fa145fa3945d88942ad06bd9c5868fc963d033ee1cfbd84f20572814ab4e04516324174a1f31274832be9b314a7b4e17c202d09a943d4 SHA512 b34bb7351f17a33e339cad2ad51419d087783b1226ae20bea658a7cf9e1e43766e229bf428cb0f1b2d133d1a216bc5a9323322f7084728429b0cf5f0213474b1
diff --git a/dev-python/python-stdnum/python-stdnum-1.17.ebuild b/dev-python/python-stdnum/python-stdnum-1.17.ebuild
new file mode 100644
index 000000000000..cced3449d63b
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.17.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="https://arthurdejong.org/python-stdnum/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies"
+
+RDEPEND="
+ vies? (
+ || (
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/suds[${PYTHON_USEDEP}]
+ )
+ )"
+
+src_prepare() {
+ sed -i -e '/with-coverage/d' setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+distutils_enable_tests nose