summaryrefslogtreecommitdiff
path: root/dev-python/python-swiftclient
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-28 19:27:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-28 19:27:52 +0000
commit4b1be5ef874aaeb61a2116048e0c2312e53f8c69 (patch)
treee2f0118b102bf7e7ad852582d410adb43f13b035 /dev-python/python-swiftclient
parent4418da21bd05d610a3450f4aa75481785ca372a0 (diff)
gentoo auto-resync : 28:02:2025 - 19:27:52next
Diffstat (limited to 'dev-python/python-swiftclient')
-rw-r--r--dev-python/python-swiftclient/Manifest2
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-4.7.0.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/python-swiftclient/Manifest b/dev-python/python-swiftclient/Manifest
index c0b51d114102..897d373c9d0d 100644
--- a/dev-python/python-swiftclient/Manifest
+++ b/dev-python/python-swiftclient/Manifest
@@ -1,3 +1,5 @@
DIST python-swiftclient-4.6.0.tar.gz 209473 BLAKE2B e35516c4e05c889af5e9e794179b2c5a5fe364bcc85492639dd58c45ffc756d86942038d683e685c9f33d876043c0953c6b0cf69db16abdf57c057cf24ab97ed SHA512 19883c2640cf6071752e09261c7d8499e01b749100e6d79cc3a83e08bffc7392ee852351b11d549001d23898d4c34e8309fdadb8e0241e301bf03300db80eef7
+DIST python_swiftclient-4.7.0.tar.gz 209719 BLAKE2B aa4155b1299fbd740e94509b13ba4c295375dbe45bf50c727ddc31e464fb1d25925fc6aa6c2aea8dffc97ecd435dfcf24ef36cfaecaa661555c34088c353626d SHA512 07ab49421260f4537d5a3093557e76cce05db1f4caa99cb54fd5f7fdd8129b73473566005d9f28e7b4fc86348f642f207b3f28cbab10da36f3c656001e86a61a
EBUILD python-swiftclient-4.6.0.ebuild 960 BLAKE2B 6a80bc2d71647be573edac85c4651a952a7e1ec92f809507ace17438cc999ee1f7ade471b9a555f24657dca684d5f5fc59fa2ae3012bf370bb24e98cf0778400 SHA512 30a862a3d0abeb44044310f3fa02d14e2fca5ebdae11e1fd3b542288ce7a03f2d31219ac378f443144514230cdfc6ab577d47645b7ace1d07c02210f1bbc84a3
+EBUILD python-swiftclient-4.7.0.ebuild 943 BLAKE2B f1c08047df9c080ab7f7320bf1f86816e020eef99c8687e652539bc000ada44bfde92f6cd76de51d6b6873ca39376ebcc47aff4b9ef852dba5b14e4cf1bcb805 SHA512 082a0b260551bf4c94bbe59021e0c4a1048c66628043b52da24a03f5b276400953b18d79e254353158b3369fd65ef4ab725fa319f25914492371ed796e06bec0
MISC metadata.xml 668 BLAKE2B 299614e07d6b3f2d4acbc301cfddff8c1699acf3dac104de483e9dafdbf4cb34c8b933fdf7d91de3c26e73f34165338f68b46a44f3a113eb68b9b0270b9819c2 SHA512 f8b012262d487c873552beffe7107c8799bff52b6c61da575a9b2fa82d899d4e30d3a57f0885a119d8aebe87d5be61ea846d0766a409396acaa5fdb2b632e248
diff --git a/dev-python/python-swiftclient/python-swiftclient-4.7.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-4.7.0.ebuild
new file mode 100644
index 000000000000..ace65050c0ad
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-4.7.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="
+ https://opendev.org/openstack/python-swiftclient/
+ https://github.com/openstack/python-swiftclient/
+ https://pypi.org/project/python-swiftclient/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/keystoneauth1-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.7.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -e 's/test_password_prompt/_&/' -i test/unit/test_shell.py || die
+ distutils-r1_python_prepare_all
+}