summaryrefslogtreecommitdiff
path: root/dev-python/python-twitter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/python-twitter
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/python-twitter')
-rw-r--r--dev-python/python-twitter/Manifest5
-rw-r--r--dev-python/python-twitter/metadata.xml13
-rw-r--r--dev-python/python-twitter/python-twitter-3.3.ebuild37
-rw-r--r--dev-python/python-twitter/python-twitter-3.4.2.ebuild66
4 files changed, 0 insertions, 121 deletions
diff --git a/dev-python/python-twitter/Manifest b/dev-python/python-twitter/Manifest
deleted file mode 100644
index f5f427728f96..000000000000
--- a/dev-python/python-twitter/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-DIST python-twitter-3.3.tar.gz 84696 BLAKE2B aad833904e0127fca4043bf66187e7ff5a4175c7c86cf9b053c7d0bc6c9f25d2bc102a631d479ebd4ce81b515aea0f058473993a1b7f5a03751dd83f39e9a3c3 SHA512 72e4133abddf86a19b8701f846df7eb99b426b8835e457455935a656f38c266fb2930d8a145d5d280ef2e0f0096511b29dcdf98b94bd53b6a661ea575cfb3265
-DIST python-twitter-3.4.2.tar.gz 5145121 BLAKE2B 2ac45ae8fde3cfccb794d8496efdb0066c887101b6a6ac55ad6fd0f9fda8f50db1245284236c5fa0fd8eb7419c11eb253777d78092ea138d2f0a5115db861a89 SHA512 23d009e006864bb9dbf9c10223531a0e2aeefd4ca59852849f49f41e36b6db29e820a58c8a43f23c7bda0c68b6eb19a5557ef649bae2cbb1f1e406f78a918f92
-EBUILD python-twitter-3.3.ebuild 868 BLAKE2B a9ff13f9562f73e78b4871c81c720ddd69aef62e2cd4bfa058fb5ee1485b0c3c77acb42449c5894bf3ed7020d04fdb01c9ea7e944fbb6a7bf0d9238a75e19848 SHA512 564b298b0705e96dd70e6d853d6fe3348492356f80a70d5f8e4584fc9485b36fa2b2b499151f61fa72ea8b7adcda2a6e630c1a79a0e158b4c6168cb495d31daa
-EBUILD python-twitter-3.4.2.ebuild 1625 BLAKE2B 0601e5af6bcb79cdd51ad9cedaa25f28af199050fbcb161fe394e51cc07d3fb67a00ce9aa0e02a68c0b72d9c219dfbe406f5c23d9548838ea63f7edb1d08e948 SHA512 3408df4466d936d45d853699d6ed8a185cbd85601a550b25fa30426b7c5a55a24e75ef5afdea511cf7fb1c867c246925d5235d60a72778992421763e65ac3e56
-MISC metadata.xml 443 BLAKE2B e04fea3c6771b010c3220bf5e6d2c3d5ef61a99a1f89ce6f1bd220f41c7e2aff1f58a8e93cc30a69e8d638cf5d4c4b6ec254f02541f8de91b09f124cdffd758a SHA512 afd79db4a927e251c94096ca6cb2a6a7fd34abb693b685843b7bbeb0c379ff82feb87ea1ee773ea5939e761cbc4d22f2e61710d286110ed27579316d52df229d
diff --git a/dev-python/python-twitter/metadata.xml b/dev-python/python-twitter/metadata.xml
deleted file mode 100644
index 8b5642ee7b08..000000000000
--- a/dev-python/python-twitter/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <upstream>
- <remote-id type="github">bear/python-twitter</remote-id>
- <remote-id type="pypi">python-twitter</remote-id>
- <bugs-to>https://github.com/bear/python-twitter/issues</bugs-to>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/python-twitter/python-twitter-3.3.ebuild b/dev-python/python-twitter/python-twitter-3.3.ebuild
deleted file mode 100644
index a317ab9ac6c2..000000000000
--- a/dev-python/python-twitter/python-twitter-3.3.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper around the Twitter API"
-HOMEPAGE="https://github.com/bear/python-twitter"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-macos"
-IUSE="examples"
-
-RDEPEND="
- dev-python/oauth2[${PYTHON_USEDEP}]
- dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/requests-oauthlib[${PYTHON_USEDEP}]"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-# Testsuite is still not convincing in its completeness
-RESTRICT="test"
-
-src_prepare() {
- distutils-r1_src_prepare
-}
-
-# https://code.google.com/p/python-twitter/issues/detail?id=259&thanks=259&ts=1400334214
-python_test() {
- esetup.py test
-}
diff --git a/dev-python/python-twitter/python-twitter-3.4.2.ebuild b/dev-python/python-twitter/python-twitter-3.4.2.ebuild
deleted file mode 100644
index 5e9c145f8a19..000000000000
--- a/dev-python/python-twitter/python-twitter-3.4.2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper around the Twitter API"
-HOMEPAGE="https://github.com/bear/python-twitter"
-# Upstream does not include tests or doc in the PyPI tarballs
-# https://github.com/bear/python-twitter/pull/572
-SRC_URI="https://github.com/bear/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-macos"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-# https://bugs.gentoo.org/624916
-RDEPEND="
- !dev-python/twitter
- dev-python/oauth2[${PYTHON_USEDEP}]
- dev-python/simplejson[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/requests-oauthlib[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/responses-0.6.1[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )
-"
-
-python_prepare_all() {
- # Not actually required unless we want to do setup.py test
- # https://github.com/bear/python-twitter/pull/573
- sed -i "s/'pytest-runner'//" setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- sphinx-build doc doc/_build/html || die
- HTML_DOCS=( doc/_build/html/. )
- fi
-}
-
-python_test() {
- py.test || die "tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- if use examples; then
- docinto examples
- dodoc -r examples/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}