summaryrefslogtreecommitdiff
path: root/dev-python/python-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-26 01:25:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-26 01:25:46 +0100
commit21dea977c89ba487b57c7856a4924950e667f209 (patch)
treeea817bd899b4d1759c030d6439f307b28e51588d /dev-python/python-utils
parentc25088d4fc442a7d6dc3a8d0498b43024888318d (diff)
gentoo auto-resync : 26:09:2024 - 01:25:46
Diffstat (limited to 'dev-python/python-utils')
-rw-r--r--dev-python/python-utils/Manifest2
-rw-r--r--dev-python/python-utils/python-utils-3.9.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-utils/Manifest b/dev-python/python-utils/Manifest
index 712c91c26b33..1a75ea28786e 100644
--- a/dev-python/python-utils/Manifest
+++ b/dev-python/python-utils/Manifest
@@ -1,3 +1,5 @@
DIST python-utils-3.8.2.tar.gz 30431 BLAKE2B 3c53c02729f601b30e68a26cd4b61e49c29f036a1327c43124e326dae173d1b528035bb0952c349ec43f3cd6e159c2e0d5e82c8c46efd12c95f445dbb20751c0 SHA512 e0de794abe95f3e205fcbde0fd52615f44128ffb702a406ff0d3f7ce2640ff60ac3cc508829245bce750ed191c9d3ae563b8f0619af4c2c43cacde6a1aa0fde4
+DIST python_utils-3.9.0.tar.gz 35352 BLAKE2B 8d247d28a1ed797d1058f6bf45469230f5fcf3f8d305e195a49229deef5d41552e07b5c2e7543223f2df608feffa6df2f57828863acc437ff9c3c2a11e797703 SHA512 fe6313b18f53a56d71a9ca9b40f7bfe61629f7c5cf0b9088adf81ed8aa78b1c5a593c59ec178ec6c87424ae0730c9cb15d6eaa1a129d871f75b67d1d4f6938bf
EBUILD python-utils-3.8.2.ebuild 893 BLAKE2B 0a746f454c52f363ec7210c388fc702c513157c930a6a9421dacd7434e63e930737bdcf5e49238670c45b86f8f0d457324c7473d866675f2ad3a99f2cb314c8f SHA512 ae36f8c4f78040b5e2ed3557204591a7a451279732ac94390a03abc2a6c669db3b5a446449846a3e9e2578f6ba6df5d3499b03e4cfd7cfbee5fa142761143968
+EBUILD python-utils-3.9.0.ebuild 875 BLAKE2B 9e9496b31d1c0ebe285b5491ed96403b3fa2d5ecedf46495e4ca35afc525bf132ca883f11ff71cd018223f86657a2e00d336b1fadb00e99b8de06e56f8cd8533 SHA512 266e1ad7a87ba32e606b727b534c5f1b9b4b013315e9b138b0e022b0ac8574a7a82fa5e5b99fccf029510b6f59e5d85a5d98091090757e19a37800138a3d6cd5
MISC metadata.xml 398 BLAKE2B 40018dd39311868fe5b37b6e03d6f6115427b84ca4cf4643b227dec910a193b547384c6cac4a97ed0f06a81c453c12ae57612e279e44a8a671b7f36a3ebc3128 SHA512 aaed2dfc1a9802d6d6d2d28d13fd478e0cee7c422992cde7994c4408690baba6c9e99ed77a55b0d3c5d966bb18cbc76c579b50f9d388a84ae204137b33c81a92
diff --git a/dev-python/python-utils/python-utils-3.9.0.ebuild b/dev-python/python-utils/python-utils-3.9.0.ebuild
new file mode 100644
index 000000000000..aa5d56d259e4
--- /dev/null
+++ b/dev-python/python-utils/python-utils-3.9.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="
+ https://github.com/WoLpH/python-utils/
+ https://pypi.org/project/python-utils/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ docs
+ _python_utils_tests/test_logger.py
+ python_utils/loguru.py
+)
+
+EPYTEST_DESELECT=(
+ # fragile
+ _python_utils_tests/test_time.py::test_timeout_generator
+)
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--mypy/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}