summaryrefslogtreecommitdiff
path: root/dev-python/python-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-27 02:00:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-27 02:00:01 +0000
commitead7697a01fd631b56240b2d58aedd98ba7f92d3 (patch)
treec73ecbedbb9db967a7dff614f5e8b79eacb79f5d /dev-python/python-utils
parent403335d7014372971e9e9267493a808d08bab48e (diff)
gentoo auto-resync : 27:11:2024 - 02:00:00
Diffstat (limited to 'dev-python/python-utils')
-rw-r--r--dev-python/python-utils/Manifest2
-rw-r--r--dev-python/python-utils/python-utils-3.9.1.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-utils/Manifest b/dev-python/python-utils/Manifest
index c28068678e84..a77e8ad1942d 100644
--- a/dev-python/python-utils/Manifest
+++ b/dev-python/python-utils/Manifest
@@ -1,3 +1,5 @@
DIST python_utils-3.9.0.tar.gz 35352 BLAKE2B 8d247d28a1ed797d1058f6bf45469230f5fcf3f8d305e195a49229deef5d41552e07b5c2e7543223f2df608feffa6df2f57828863acc437ff9c3c2a11e797703 SHA512 fe6313b18f53a56d71a9ca9b40f7bfe61629f7c5cf0b9088adf81ed8aa78b1c5a593c59ec178ec6c87424ae0730c9cb15d6eaa1a129d871f75b67d1d4f6938bf
+DIST python_utils-3.9.1.tar.gz 35403 BLAKE2B 8cad7a9dbbc1a2d537d1fe7342846f1b1da15d41934cef861fcc0ad8da68d67fbab8f33ab6b579ff0f67d8c8dada6411a8087b46f9682990e7c2410802009c05 SHA512 f458446edde989ad338d20b11b2486148848c9373ef627938ccff99ab186517594428d7ec068d0d110a04c8ceee665735d33c662592b96920b8faf8aeb065239
EBUILD python-utils-3.9.0.ebuild 873 BLAKE2B bcfdb8666b215463d40ba2a80d0d4bb2944f8999f795a65944e972db290485d43aa4901a5763871beb243f00f2f703c7aace56bf3856679e6defde114fc6815c SHA512 e45232565cbf9b4f32739cf92b8caf2d150be843779c7695976a4cc7d1b83987b61e9f478eeb9f0cbf9d407e7ec7779893b744c65316719c9ff702c3e55f805f
+EBUILD python-utils-3.9.1.ebuild 875 BLAKE2B 9e9496b31d1c0ebe285b5491ed96403b3fa2d5ecedf46495e4ca35afc525bf132ca883f11ff71cd018223f86657a2e00d336b1fadb00e99b8de06e56f8cd8533 SHA512 266e1ad7a87ba32e606b727b534c5f1b9b4b013315e9b138b0e022b0ac8574a7a82fa5e5b99fccf029510b6f59e5d85a5d98091090757e19a37800138a3d6cd5
MISC metadata.xml 398 BLAKE2B 40018dd39311868fe5b37b6e03d6f6115427b84ca4cf4643b227dec910a193b547384c6cac4a97ed0f06a81c453c12ae57612e279e44a8a671b7f36a3ebc3128 SHA512 aaed2dfc1a9802d6d6d2d28d13fd478e0cee7c422992cde7994c4408690baba6c9e99ed77a55b0d3c5d966bb18cbc76c579b50f9d388a84ae204137b33c81a92
diff --git a/dev-python/python-utils/python-utils-3.9.1.ebuild b/dev-python/python-utils/python-utils-3.9.1.ebuild
new file mode 100644
index 000000000000..aa5d56d259e4
--- /dev/null
+++ b/dev-python/python-utils/python-utils-3.9.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="
+ https://github.com/WoLpH/python-utils/
+ https://pypi.org/project/python-utils/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ docs
+ _python_utils_tests/test_logger.py
+ python_utils/loguru.py
+)
+
+EPYTEST_DESELECT=(
+ # fragile
+ _python_utils_tests/test_time.py::test_timeout_generator
+)
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--mypy/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}