summaryrefslogtreecommitdiff
path: root/dev-python/python-xcaplib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/python-xcaplib
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/python-xcaplib')
-rw-r--r--dev-python/python-xcaplib/Manifest4
-rw-r--r--dev-python/python-xcaplib/metadata.xml21
-rw-r--r--dev-python/python-xcaplib/python-xcaplib-1.1.0.ebuild24
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/python-xcaplib/Manifest b/dev-python/python-xcaplib/Manifest
new file mode 100644
index 000000000000..f39b979f8552
--- /dev/null
+++ b/dev-python/python-xcaplib/Manifest
@@ -0,0 +1,4 @@
+DIST python-xcaplib-1.1.0.tar.gz 22892 SHA256 2f8ea6fe7d005104ef1d854aa87bd8ee85ca242a70cde42f409f8e5557f864b3 SHA512 140a12e39decdd15c06816cf5969baaf82437f010592ee2f4b7309db585aaa6611ab3af50e399bb18d216ae1586b5ebf18490d74c385a99d6673171bcf437395 WHIRLPOOL 711eb094be643613a117044d2c3ea054bf728ff21a1efe668d27bebe912c67463cb15b8e0c052699f01439a6631c2570ba1e79d452cc5250383200fb2f54830b
+EBUILD python-xcaplib-1.1.0.ebuild 550 SHA256 fabcb37522ae4a7f75f8d14c835aeab34720d41dd402c31da3eefa5b24bb2941 SHA512 146b060138860ed504179f1d96c808a54c1cfb2e5d8b27f83df683353b50e200892f73471bc6bddbfc9bd4d8161ca0bd281c428cb96fb126fee3516defa87055 WHIRLPOOL 659daa5147a10555d3e7efc12bb74950c42e1339ba15bd973ee943105d9981e3c7b8293445de259eddad7c2aa650940e449d1acc173a14eb46b84a81d7a23f60
+MISC ChangeLog 973 SHA256 92da3887e170ab0c30db9aa9b27e433c6a2fd229bdbdfb0fd2633c7bf30ea9fc SHA512 906e2d85c91c7fe70f311c01b8aae031145610a8f6f205da0581b8f3e6338a3563bc4d1312c1673b587e7fe4df8ddce4058bdcfd537afbc7116493808bc0f65c WHIRLPOOL 29f276b9f09fc04e576d05de8f19709899cdebbc13c629843ce01a5995255912b999d7afa796bdd7ffc86b3b1894aec0a966720ba479a8e4599a93d6975261e1
+MISC metadata.xml 898 SHA256 1c9c2f2316662d0ff3723cd57dc468ed7a2dda707cfe82f3206e935a9e95ce83 SHA512 6da7eaed0415c31d9ca6591e62a0308ef8f8e7f5849131ee7c4ad26a04f7f8f751784d71e880db304928597be1f0e1352c0e328d3464c147cfe37f1550a3cedf WHIRLPOOL 872a3f2e9a33ee664f2ce1b42d116999d3caf1c33c5466ceaf7fbd0960deaf03fa98559b2cfcca84e52a8f0c9dafbc47281ef7c44fbf442f15c8e677bdd5d81d
diff --git a/dev-python/python-xcaplib/metadata.xml b/dev-python/python-xcaplib/metadata.xml
new file mode 100644
index 000000000000..e28a9e7635cb
--- /dev/null
+++ b/dev-python/python-xcaplib/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ XCAP protocol, defined in RFC 4825, allows a client to read, write,
+ and modify application configuration data stored in XML format on a
+ server. XCAP maps XML document sub-trees and element attributes to
+ HTTP URIs, so that these components can be directly accessed by HTTP.
+ An XCAP server used by XCAP clients to store data like presence
+ policy in combination with a SIP Presence server that supports
+ PUBLISH/SUBSCRIBE/NOTIFY SIP methods can provide a complete SIP
+ SIMPLE solution.
+
+ The XCAP client example script provided by this package can be used to
+ manage documents on an XCAP server.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/python-xcaplib/python-xcaplib-1.1.0.ebuild b/dev-python/python-xcaplib/python-xcaplib-1.1.0.ebuild
new file mode 100644
index 000000000000..4283bacd35f0
--- /dev/null
+++ b/dev-python/python-xcaplib/python-xcaplib-1.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_REQ_USE="ssl,xml"
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for managing XML documents on XCAP server"
+HOMEPAGE="http://sipsimpleclient.org"
+SRC_URI="http://download.ag-projects.com/XCAP/python-xcaplib-${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/python-application[${PYTHON_USEDEP}]
+"