summaryrefslogtreecommitdiff
path: root/dev-python/python3-discogs-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-18 00:14:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-18 00:14:44 +0000
commit5264c18a325553759d67fb4e059db03cf3fc5c81 (patch)
tree588a7d54829b20df6c11016213dad5808b5c706a /dev-python/python3-discogs-client
parent27b3683509c5229cce540418778a8b64afbc0009 (diff)
gentoo auto-resync : 18:02:2025 - 00:14:44
Diffstat (limited to 'dev-python/python3-discogs-client')
-rw-r--r--dev-python/python3-discogs-client/Manifest2
-rw-r--r--dev-python/python3-discogs-client/python3-discogs-client-2.8.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python3-discogs-client/Manifest b/dev-python/python3-discogs-client/Manifest
index b4dfe6241fa0..89402b5daa1b 100644
--- a/dev-python/python3-discogs-client/Manifest
+++ b/dev-python/python3-discogs-client/Manifest
@@ -1,4 +1,6 @@
DIST python3_discogs_client-2.7.1.tar.gz 36930 BLAKE2B f0e6071759e8e14f4e78fc0cd15fe4643b1984be622e9fdbf28bda11699d4f7d829eaa7aee005c888e556b6c994585b1a5f2c12351a995f2937af87c360f5292 SHA512 4b9ca0fb1498319f814b88f2df6a1bd3d7c02f44bea8a13aa6b640d3d87def825dcc79181afddb173fedb7448f99a8f4a244915ebfaf26dd2411db8d151b054c
+DIST python3_discogs_client-2.8.tar.gz 37416 BLAKE2B aec54b1fa383c673a94dbc9f8f3ff6dbf580b741ebeb2851b76224f5fe408bb316bbf83b42cde15569261eb3e3a4529312c2cb900f8c2a3b0b8bdbe27b50bd98 SHA512 7137ba2c298318cbdb2a0e41c3780c62c4780fbcfc77f03cc88341f7b7e42fdb8962ce91713d5bccd4afcd6173e0b4a2198a6b50b4b90c0baf05cb03746f6d5f
EBUILD python3-discogs-client-2.7.1.ebuild 737 BLAKE2B 2df48eba9cb1f4fcfce98a26934d2952782791f02de67c9a250d91dec0249ba5e9b8d0a993a6f4a7e95416d140e5697a4f0879d0d05eb2a91f43bb1e246e5906 SHA512 fbe848850a9a07925ad725f13e970d0fbc68fe859668e7ec0b1dd3f9fb11e9a9f823cf08049fa5fb93e7b768a3a0b8e7c004f9f4622c6364116e083d182e03f3
+EBUILD python3-discogs-client-2.8.ebuild 739 BLAKE2B 190b6c19ddb68858d1aaf50dc857b01a117e10741a77c4f3959dfc6a41d81592476b3ceaa0daaddc85d22dc09cc2504df5539d446249aa54e0b8dc377292bc37 SHA512 bdfa39a6d6b3bf513561a562dbd3a1c451226a3a975a29639276444cd4bfa2863df8a8bcce530fe805b23fc18629f25dff2c633febfa3dc2a8934439b9456b92
EBUILD python3-discogs-client-9999.ebuild 739 BLAKE2B 65b9f4bf37f226ef8ae3fb46a4c0de93365e6be62dd804d954b3ed317757568b20b37e817fe30fca725551d9c7a48e8dc428b71dac4d5c705da3b74dbb5e7f76 SHA512 3e25ef8a907779721bb4e1c97dccc4532ae008157d2c993193f162031d447bd339eeffc43c3eb288e3b66e9d68f345d53242b709b36365828116899d9ad34a01
MISC metadata.xml 674 BLAKE2B 5c0dd431ad4633cbc7ddaa97e54e9f5b3eb67ed28e07ac313f218fd055e0042365c270e83153627decd196aca49db12304da87f2c74f20bc454fd8e5b4b8fb46 SHA512 ad582419be3887c5fa3c0d630ad32575f378453dd4f7a8c33df91db31b495caa88707214f7e456d69027532540a474c41ad8336b40e90229f1f31cd3193d7f82
diff --git a/dev-python/python3-discogs-client/python3-discogs-client-2.8.ebuild b/dev-python/python3-discogs-client/python3-discogs-client-2.8.ebuild
new file mode 100644
index 000000000000..9ac2f3836dd5
--- /dev/null
+++ b/dev-python/python3-discogs-client/python3-discogs-client-2.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/joalla/discogs_client.git"
+ inherit git-r3
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DESCRIPTION="Continuation of the official Python API client for Discogs"
+HOMEPAGE="
+ https://github.com/joalla/discogs_client/
+ https://pypi.org/project/python3-discogs-client/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest