summaryrefslogtreecommitdiff
path: root/dev-python/python3-openid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-26 00:10:07 +0100
commit95461df035e3867364495f065e5e805bf629b2d7 (patch)
tree867dce371a84a696e91be255d89f282975aa0480 /dev-python/python3-openid
parent46eedbedafdb0040c37884982d4c775ce277fb7b (diff)
gentoo resync : 25.10.2021
Diffstat (limited to 'dev-python/python3-openid')
-rw-r--r--dev-python/python3-openid/Manifest2
-rw-r--r--dev-python/python3-openid/python3-openid-3.2.0.ebuild18
2 files changed, 15 insertions, 5 deletions
diff --git a/dev-python/python3-openid/Manifest b/dev-python/python3-openid/Manifest
index 84685172657d..9312bfedcf3c 100644
--- a/dev-python/python3-openid/Manifest
+++ b/dev-python/python3-openid/Manifest
@@ -1,3 +1,3 @@
DIST python3-openid-3.2.0.tar.gz 305600 BLAKE2B d793eb61335d7240d5c25324b8377d19781df15012c8da6d5d0d7445c8a7fcb31711156b48d32efae8b6de27509e8f9112535ece7820779ca9b7f2e7be04fb0f SHA512 54412820fef21928e1bf30d16c9bc73d454e9ff41df028a12047c08abdb4c2c9e1d9053daebab8b0327cb0fe0f67e364c2506a47509fef6db5bff42f8399b799
-EBUILD python3-openid-3.2.0.ebuild 522 BLAKE2B 6e0941245eac5b9b4d578b4112878c162b1b95f81e102b823dc5fcb28b83b1cecb54de4ba4f3e20abc960a6a1bba16910a8f35f968efd137b93a4e5c79300dba SHA512 925d97b47a31836fe52ba635ededb3ce45731b8d667a3b5759d58c43fa6cb216287795c8a6eeb8f60634d49d5343f73dc9fd2dbad3867272f9d64ba5b1ac0c48
+EBUILD python3-openid-3.2.0.ebuild 725 BLAKE2B e4132d8a1d215feea68aa6122d1430a402aafac26d7095bc290afe0a11bd719ea28badbf42012f73b5256c6fb1ab3fd848e69cb58b76856b23a05e89dce36f1f SHA512 657ce8cf2f1a86c459d0a4261e346a0d273394e010859b8fab008497cfdb92bcba59cfd705a68a1c962463232838887c43a3ea2cde6c7cb6b2ae39d5ba9c902c
MISC metadata.xml 356 BLAKE2B 9b59b5e374b06608bf65fb653f038851282482aa74102688003e5e21bbaa3447c01205ca92425761510651cb4bdb1ea2b5f7edb663daa4088c7d273e88df2fde SHA512 317b8fb4594458a2ef89845f12449b6b26021aa25ba3726b5767ffb161d1ced925c12d0834801145cca86af495b4fe867ecd87baf0cbc71c6acd17d6994b7202
diff --git a/dev-python/python3-openid/python3-openid-3.2.0.ebuild b/dev-python/python3-openid/python3-openid-3.2.0.ebuild
index c1f5bca4f6c8..6066e6b63193 100644
--- a/dev-python/python3-openid/python3-openid-3.2.0.ebuild
+++ b/dev-python/python3-openid/python3-openid-3.2.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -14,9 +14,19 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
+IUSE="test"
+RESTRICT="!test? ( test )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="dev-python/defusedxml[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND}
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/psycopg[${PYTHON_USEDEP}]
+ )
+"
DOCS=( NEWS.md README.md )
+
+python_test() {
+ "${EPYTHON}" -m unittest -v openid.test.test_suite || die "Tests failed with ${EPYTHON}"
+}