summaryrefslogtreecommitdiff
path: root/dev-python/python3-saml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /dev-python/python3-saml
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'dev-python/python3-saml')
-rw-r--r--dev-python/python3-saml/Manifest2
-rw-r--r--dev-python/python3-saml/python3-saml-1.10.1.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python3-saml/Manifest b/dev-python/python3-saml/Manifest
index 354a7e5f17df..4a5699b2af1b 100644
--- a/dev-python/python3-saml/Manifest
+++ b/dev-python/python3-saml/Manifest
@@ -1,5 +1,7 @@
DIST python3-saml-1.10.0.tar.gz 503005 BLAKE2B 88be9b00082d00c86081432dd6789c0f040e8e210d3d1de218f8bf7a41cf32acce6aa90f92b6e083142a2a5c8f820eb9f8b6e880e742400b8bb83e7eb28db392 SHA512 82d15ef4315d25b38506177cbb4ef095a0546705035491847597b353486e119026c700f5d4d22764c93646f645e13d93d75bd3541c2c5b31343bcee35a42ead3
+DIST python3-saml-1.10.1.tar.gz 503178 BLAKE2B 6c87f26db03799ee92211baf1216751c293ae6182d8f8abb094fcc47c2c28ca7be933b64b0dc3cbd52ea55a0cd19c4fc96a71bb89839d41fdd3eb3daee21d293 SHA512 64bd3fc11749ef8340fa59788277e5213edec6d93f7924e412e517846623dce88b97c407ca7ae0d58172cc78a8b713c2916fe5c29df3419fa10f34b84bdb549c
DIST python3-saml-1.9.0.tar.gz 497106 BLAKE2B c3b282be835dcd0590125563ed0380bbb5d486aeffd60fa0d6a1e7d22b25ffaa03a1bea555520b1465b27b352df0936d21b919ce73a3671d63f07a52b3efdb37 SHA512 a5171258b917c02f10a0c420a19fe6829a034df1dfd87135351b9c187314dca2f973012f49056f391444aba76306adfd48cd77a859274d5cbd2a8c23a00af78d
EBUILD python3-saml-1.10.0.ebuild 845 BLAKE2B baf652ce7709f85ed5b297b49eacf78c19b3c566336045d48d7502ca37ec57202badfcce3f66044b734125be6856f752ff0147f96e2ed34f11d64f973f1c2bf7 SHA512 610d9880ff8852265e68898536e2a0e0db02ca1232ed4392b9717a5a1d02c7176be38c34ab979860989d09425ce86b22f0c4f50a87acba23c70d1cfa4fe4eff4
+EBUILD python3-saml-1.10.1.ebuild 845 BLAKE2B baf652ce7709f85ed5b297b49eacf78c19b3c566336045d48d7502ca37ec57202badfcce3f66044b734125be6856f752ff0147f96e2ed34f11d64f973f1c2bf7 SHA512 610d9880ff8852265e68898536e2a0e0db02ca1232ed4392b9717a5a1d02c7176be38c34ab979860989d09425ce86b22f0c4f50a87acba23c70d1cfa4fe4eff4
EBUILD python3-saml-1.9.0.ebuild 737 BLAKE2B dfe2a322187209c39ded3053130418f2ee03830239c33aa82838e755caa1318881b8ba93071921284380761e672f38a54390a7652c8b6ba06f112a13189be5a7 SHA512 a62859afaaa19b10c09f045e47655deb57ab7ecd11fc0fc39770893bf0b78df9019cc41fea4d85e6afae92bb12544e58cb7b492c45dba82014ed3bae2c73d291
MISC metadata.xml 486 BLAKE2B 1f23cbaa3e1036247a248e4260dd6688ffd05880a4bb551c8ec3106257875936854478c84fdf4c5c2a47c9d7f32f71dc57ec73c1e9e53744126bcc18a820d420 SHA512 0a6c9d48a664bf598dcafa1dc72074f4abbb730b31b29fa84d01d00d95694669b9210df84a3b18baf5384caa4b9f483412769150b25ba1acf0101c47347d1781
diff --git a/dev-python/python3-saml/python3-saml-1.10.1.ebuild b/dev-python/python3-saml/python3-saml-1.10.1.ebuild
new file mode 100644
index 000000000000..ca0bb11a6cd7
--- /dev/null
+++ b/dev-python/python3-saml/python3-saml-1.10.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="OneLogin's SAML Python Toolkit"
+HOMEPAGE="https://github.com/onelogin/python3-saml
+ https://pypi.org/project/python3-saml/"
+SRC_URI="https://github.com/onelogin/python3-saml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/isodate-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.3.5[${PYTHON_USEDEP}]
+ >=dev-python/python-xmlsec-1.0.5[${PYTHON_USEDEP}]
+ >=dev-python/defusedxml-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ # unpin deps
+ sed -i -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}