summaryrefslogtreecommitdiff
path: root/dev-python/pythondialog/pythondialog-3.2.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pythondialog/pythondialog-3.2.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pythondialog/pythondialog-3.2.2.ebuild')
-rw-r--r--dev-python/pythondialog/pythondialog-3.2.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pythondialog/pythondialog-3.2.2.ebuild b/dev-python/pythondialog/pythondialog-3.2.2.ebuild
new file mode 100644
index 000000000000..69af5d8f70ed
--- /dev/null
+++ b/dev-python/pythondialog/pythondialog-3.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python3_4 pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python module for making simple text/console-mode user interfaces"
+HOMEPAGE="http://pythondialog.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pythondialog//${PV}/python3-${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ia64 ppc sparc x86"
+IUSE="doc examples"
+
+RDEPEND="dev-util/dialog"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+}