summaryrefslogtreecommitdiff
path: root/dev-python/pythran
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-17 19:04:28 +0100
commit514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (patch)
tree555c194dbeb0fb2ac4ad3cde7c0f6a80fd330ce2 /dev-python/pythran
parent4df3bf9762850b34cd1ead5c80374d1a0fc3362e (diff)
gentoo resync : 17.07.2021
Diffstat (limited to 'dev-python/pythran')
-rw-r--r--dev-python/pythran/Manifest2
-rw-r--r--dev-python/pythran/pythran-0.9.12_p1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pythran/Manifest b/dev-python/pythran/Manifest
index 5bfad814a2f4..3e2288e9c18e 100644
--- a/dev-python/pythran/Manifest
+++ b/dev-python/pythran/Manifest
@@ -1,3 +1,5 @@
DIST pythran-0.9.11.gh.tar.gz 3570395 BLAKE2B deada9a608ed3d883308389d5a6ddfee2f0f74ecc74f1fd87bcee75eecabcab2acd576425b8e92d6fc6b212377f1c7295e766db32082339c98670a964a49ea10 SHA512 c8939b918216803ad8e2a133b16f0d8ea939e4d87d07ddb1a3d131afb0ddb76962c489270431808fbf129e76b5f9dbdc2b625097f37df2eefdb9834d319d028a
+DIST pythran-0.9.12.post1.gh.tar.gz 3612135 BLAKE2B 1c0650d249a0834a488aba6f48d1130b8897b4b220523d3aaa0f7557609f9cfcc208563980b6855132199fd394b45404c4c15c961380ea2089121c5c9eea65b2 SHA512 71a9dec2ca9eca85a2b3e52022e262135b4f1642d646bfc66323bd8b7545a11351d70aaec0fd90d82dc0ba23ec6733a30c8d807e5d90ff5c208d2995a6ac6f83
EBUILD pythran-0.9.11.ebuild 1183 BLAKE2B 7c810169aff4d52fe1d23dcbb0dcf75a61f342ae4b2e7f47b01c8ae966389638cb38700bf06fa3e1285d8664706dbb6c6bbcef528a0e76652bb0bf5b8d5b0dd7 SHA512 53c038ee10e4411ade77b3917554f46a38354cd4855e854df6842654f4ba3d6c3ab616d4898ba164bfea2c9b38939ea2aee8b7adc6ecca25625534bdea7fde6b
+EBUILD pythran-0.9.12_p1.ebuild 1119 BLAKE2B 9d5b29d81e994b29b5463d6b9a3cd1dedd732bd2a15315c0fbbe3489873d1e8cf53d2abf1a0a8a7a1960da57bb79fcdadf12eb5aac08b05805a6b25734dfd850 SHA512 cc528373ec1f9d0cf50256422dd8f074b4f9066b578004e45a0a25fc99ffa9224591897d50f2cfce6266d83cda5e239b2a93f1c01d83105c970dcd999230e8e5
MISC metadata.xml 353 BLAKE2B 3584e4357ca55b22b1bf1c707b22df13999c358ce3968fd968c2cb94db6014e325b6782b8bb2b6e97a7a6c584081fa974ddf01ea88103b51cbd0bd2b49300bb4 SHA512 13435a1f1b2de15e825165e9d71ad3f12f29f32fe55694b7e504b76a5b6738bf4ff7b2626b0c956a1edb66d744b3589dac320eca4af0db5e6c55f3ddf537550f
diff --git a/dev-python/pythran/pythran-0.9.12_p1.ebuild b/dev-python/pythran/pythran-0.9.12_p1.ebuild
new file mode 100644
index 000000000000..6cf9f49801e9
--- /dev/null
+++ b/dev-python/pythran/pythran-0.9.12_p1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 multiprocessing
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Ahead of Time compiler for numeric kernels"
+HOMEPAGE="
+ https://pypi.org/project/pythran/
+ https://github.com/serge-sans-paille/pythran/"
+SRC_URI="
+ https://github.com/serge-sans-paille/pythran/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/beniget-0.4*[${PYTHON_USEDEP}]
+ =dev-python/gast-0.5*[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ virtual/cblas
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/pytest-runner/d' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x COLUMNS=80
+ epytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}