summaryrefslogtreecommitdiff
path: root/dev-python/pytidylib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pytidylib
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pytidylib')
-rw-r--r--dev-python/pytidylib/Manifest4
-rw-r--r--dev-python/pytidylib/metadata.xml12
-rw-r--r--dev-python/pytidylib/pytidylib-0.2.4.ebuild25
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pytidylib/Manifest b/dev-python/pytidylib/Manifest
new file mode 100644
index 000000000000..00907050055c
--- /dev/null
+++ b/dev-python/pytidylib/Manifest
@@ -0,0 +1,4 @@
+DIST pytidylib-0.2.4.tar.gz 86650 SHA256 0af07bd8ebd256af70ca925ada9337faf16d85b3072624f975136a5134150ab6 SHA512 443e9af0fd458d4f041e3b72415839838a4edc83f8a978e5cc0bdf53202584e269f1ad5df10967d8ae4b98b24dcffcf9f5a54e0e3f6cd620a8a6a20171da0811 WHIRLPOOL c2b4665982333001a44592e7b80ae69926c6e9e1ad0c5f78eb89a1fb3d0f6e80dc1687b34f8f643ce93dc32c521886e0a010b9d63f71e3b98c65b61c5dad7328
+EBUILD pytidylib-0.2.4.ebuild 630 SHA256 f682cdf23d2af1dd78cd106df7503a65732692f4837abdc510658c01b25e95c2 SHA512 a66aacd2afeae150aaebc9d007e42cd46d0fffd0c9b1279eb7e65049ebf45b5354683f4d34ad1139f6a99a16c6aea539697142dc3088ec4b0872b80c517ab4a1 WHIRLPOOL f5095bdb9e51ba3a75511a8b5c8a33ef2700f61dba379aaf953970020ac59764bc99144b040663787acaaae81f95e03d2828c13a38bea8ed36c3de31e3aacbb5
+MISC ChangeLog 1809 SHA256 c0f722be42aeb5081ed1395ea2dd14d9fb0166ace721adbeb228874258be0584 SHA512 b6f349cba6dd2ca9add47e2c95fd98ab968128c49dfd0a3a266262488fd2d8f8c0e98e6b8d9c4d6f36208690102214767e9604e38df31d69f2cebd8c84c992ab WHIRLPOOL 60faa61c4d61be01df8e6d5f34c3175636271da6cf35c2fccc66abce32c933f40ce8b34d62747f3d0f27e1db4a7e385f349ade7bdbd56cdcac2a1c167dbc9b68
+MISC metadata.xml 385 SHA256 49ede5c804d24dc8c6882b6517fcc570c925d26fc0a5d00e42556d9f8ed58edc SHA512 e41d4897a343c45e469fe4cd52a7ce93d525ea208dd570fe0517feda8f445fa9175d971e4c37b8f1941a7cb6931ff6473526ced82384489f02a11c4040fec933 WHIRLPOOL e4f455f6150a3d3a3318a8d850bd8952a54dec7e77cf924800da1237a7348de5727da0786156a1e6fb64ec8e6fb8bde3daf39a740ede0bd51f16811334a8c21b
diff --git a/dev-python/pytidylib/metadata.xml b/dev-python/pytidylib/metadata.xml
new file mode 100644
index 000000000000..9badc222f9f2
--- /dev/null
+++ b/dev-python/pytidylib/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">countergram/pytidylib</remote-id>
+ <remote-id type="pypi">pytidylib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytidylib/pytidylib-0.2.4.ebuild b/dev-python/pytidylib/pytidylib-0.2.4.ebuild
new file mode 100644
index 000000000000..6e0e640afb9b
--- /dev/null
+++ b/dev-python/pytidylib/pytidylib-0.2.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for HTML Tidy (tidylib)"
+HOMEPAGE="http://countergram.com/open-source/pytidylib https://github.com/countergram/pytidylib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="test"
+
+RDEPEND="app-text/htmltidy"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest )"
+
+python_test() {
+ py.test -vv || die
+}