summaryrefslogtreecommitdiff
path: root/dev-python/pytz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-05 10:23:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-05 10:23:18 +0100
commit9aa62a2a35904a08cbf2e884d3abd89d893daf91 (patch)
tree9f612bb8f368bfd5d14d84f9922b073302e85d30 /dev-python/pytz
parentb89f5897f4301157fb1a4af17e0c941703a2579c (diff)
gentoo auto-resync : 05:09:2023 - 10:23:17
Diffstat (limited to 'dev-python/pytz')
-rw-r--r--dev-python/pytz/Manifest2
-rw-r--r--dev-python/pytz/pytz-2023.3_p1.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pytz/Manifest b/dev-python/pytz/Manifest
index a65cecbd5375..754da2aece75 100644
--- a/dev-python/pytz/Manifest
+++ b/dev-python/pytz/Manifest
@@ -1,4 +1,6 @@
AUX pytz-2023.2-system-tzinfo.patch 1787 BLAKE2B 52026a74040573aa97a86ee6e8c5afb56114297182116a375b9b9fc5e8840edba4e4e5eeeadf386a9f9d84302d71ec4ab55098b4b9d3d67db73043d7c0a52f79 SHA512 23fce20b8d91bdd1436efb611c5593340984ad27ed5a5fbcebb7472b189e7e66a391c6e6925f3f4a33cae49f527453fdc1075c162ef6976614d1b398d5abe625
+DIST pytz-2023.3.post1.tar.gz 316899 BLAKE2B 3274e11c38b34eae42089cacf92e537f1376fa721294ea2da3a68fe3491e7e95d1c88cb4687d1e83965be4730504373c72960f5dc5e9b6a8a339e541476515f4 SHA512 c2f1bd52e42c7d1014b8aebf3544b865eb5ae5e17146253406def72785af14bcfe34b9db6b71ca91a3c988c496fbe93e5d1731bee66349463c992be619d21f2c
DIST pytz-2023.3.tar.gz 317095 BLAKE2B dd2fe27471f641382667ddac77216f9e0e22dd0059b78ecb14be5490dd568cc4865a5624f8e89534a868fde5ea9c51fd3620a3cc1ed30ab32fc5b39445abeb14 SHA512 3a39e9ec22bf1468e7415f60f10bf4a4e5b0b12bea2aeec45c5e63a916136c747fa0abd1b0612a99da962e743f28f24ebc43c1d73d96f0e98f7fb0ae6b62e319
EBUILD pytz-2023.3-r1.ebuild 1187 BLAKE2B 1930c83e517ae6c60bd268d8940b88a5c58f5d2b80de7b369754fa7c2b714d4082f2ddd898a10c172b35bf89c4ec93c1e8a28ac3ef1549dcf95c31108de4b3e4 SHA512 f738c835bcf0260e774d190d1352939be4225e90b82aa60b7c88b352e9d7bfe9356f940ca132024c0da51d00b781742f382b1b91e9199d6daf7277406015c82c
+EBUILD pytz-2023.3_p1.ebuild 1195 BLAKE2B a7b1e0b1e9059807d73194bdeecfc99ed38d58446e72cc49469c632c017732cd5c4269d32137de5d5afceacaae3e473effd6e69a08b101c604c066c38150c350 SHA512 834d7dfa3720314e83319269d5918b3eceb414f93239732346c4bcd98bf6b9022db2155530b869b25da7ccee2f835ade8c3488f19be0d06b2ca7bd5789de1b1d
MISC metadata.xml 820 BLAKE2B 224acaf3f2b85e717829a59108a4053e9a60bc710c330b12dc3f181685d5c8ab1b090105796f092004b1a70781882438b0c0a27bc96ef0116b33fe7051cc6ad5 SHA512 c9a677d89a9f831f3a9833b02e6cec36adbb27688e117b66caad32d3be10fca19787dd85eb14e21eb95d6ed8ba6ff02122ad9f54aa175252834dc4c219b7c219
diff --git a/dev-python/pytz/pytz-2023.3_p1.ebuild b/dev-python/pytz/pytz-2023.3_p1.ebuild
new file mode 100644
index 000000000000..1a39f4907ea6
--- /dev/null
+++ b/dev-python/pytz/pytz-2023.3_p1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="World timezone definitions for Python"
+HOMEPAGE="
+ https://pythonhosted.org/pytz/
+ https://github.com/stub42/pytz/
+ https://pypi.org/project/pytz/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ || (
+ >=sys-libs/timezone-data-2023b
+ sys-libs/glibc[vanilla]
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ )
+"
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unbundle timezone-data
+ rm -r pytz/zoneinfo || die
+ # remove hardcoded list of all timezones but leave subjective set
+ # of "common timezones"
+ sed -i -e '/^_all_timezones_unchecked/,/^all_timezones_set/d' pytz/__init__.py || die
+ eapply "${FILESDIR}"/pytz-2023.2-system-tzinfo.patch
+}
+
+python_test() {
+ "${EPYTHON}" pytz/tests/test_tzinfo.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}