summaryrefslogtreecommitdiff
path: root/dev-python/pyuv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/pyuv
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyuv')
-rw-r--r--dev-python/pyuv/Manifest3
-rw-r--r--dev-python/pyuv/metadata.xml40
-rw-r--r--dev-python/pyuv/pyuv-1.2.0.ebuild28
3 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/pyuv/Manifest b/dev-python/pyuv/Manifest
deleted file mode 100644
index 609fbe1fe5ee..000000000000
--- a/dev-python/pyuv/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST pyuv-1.2.0.tar.gz 98578 BLAKE2B 01f7bfd2b3a7d2480ebef75c746a5f2d7b0212b6fa562122df2d7fefbdf4b2c63017836f316f5d6d9ae7d7cbeb2ff0d24ab3d04f4e9d15370b6d6077175611d6 SHA512 10a8448700c609b6e9844c6bc9bd6428920a455c94bee79569006f783c7f5d2683abe46c4692d0f0016a621d0c6d0ef2decc42a9f0418e1242b79ab0f06ee9f2
-EBUILD pyuv-1.2.0.ebuild 635 BLAKE2B b8c62c21464b1d265075da02ec7db9da65eb23e24fe5f7712188b8bf352311f1b07973ed2eb1a4054628321c4b8737fa8e39f1e9b3c56a1d74cae18619845691 SHA512 27828bf8ff98cdd46693121142d79a24ec23e39f6fbf1f1828918c71717088019682219fd80d5c92edb7d8a2e57ae648ef444aaaefc2000d7632cd85e0154057
-MISC metadata.xml 1336 BLAKE2B 43efbba576edd19d05e2ddb3ef504445f33606c257fd80be52191d3a532e8a8156e9200cf80c58a975cef580116f0758cad94b59a98b2c7e9646682dd479ac9d SHA512 5188d8c0336c9583d15da1a82f8c6866bbcd806d4e6025bc9cbdf450ae1d02d394c2bb5186d74b3f7e05c071612071d9033358918fa11cc2114f9c5eaf56d01c
diff --git a/dev-python/pyuv/metadata.xml b/dev-python/pyuv/metadata.xml
deleted file mode 100644
index 5631539a3d3f..000000000000
--- a/dev-python/pyuv/metadata.xml
+++ /dev/null
@@ -1,40 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <longdescription lang="en">
- pyuv is a Python module which provides an interface to
- <pkg>dev-libs/libuv</pkg>.
- libuv is a high performance asynchronous networking and platform
- abstraction library.
-
- libuv is built on top of epoll/kequeue/event ports/etc on Unix and
- IOCP on Windows systems providing a consistent API on top of them.
-
- pyuv's features:
- * Non-blocking TCP sockets
- * Non-blocking named pipes
- * UDP support (including multicast)
- * Timers
- * Child process spawning
- * Asynchronous DNS resolution (getaddrinfo)
- * Asynchronous file system APIs
- * High resolution time
- * System memory information
- * System CPUs information
- * Network interfaces information
- * Thread pool scheduling
- * ANSI escape code controlled TTY
- * File system events (inotify style and stat based)
- * IPC and TCP socket sharing between processes
- * Arbitrary file descriptor polling
- * Thread synchronization primitives
- </longdescription>
- <upstream>
- <maintainer status="active">
- <email>saghul@gmail.com</email>
- <name>Saúl Ibarra Corretgé</name>
- </maintainer>
- <remote-id type="github">saghul/pyuv</remote-id>
- <remote-id type="pypi">pyuv</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pyuv/pyuv-1.2.0.ebuild b/dev-python/pyuv/pyuv-1.2.0.ebuild
deleted file mode 100644
index f7e08dd69587..000000000000
--- a/dev-python/pyuv/pyuv-1.2.0.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python interface for libuv"
-HOMEPAGE="https://pyuv.readthedocs.org/en"
-SRC_URI="https://github.com/saghul/pyuv/archive/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# https://github.com/saghul/pyuv/blob/v1.x/setup_libuv.py#L117
-RDEPEND=">=dev-libs/libuv-1.7.3:0/1"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/pyuv-pyuv-${PV}"
-
-src_configure() {
- mydistutilsargs=( build_ext --use-system-libuv )
- distutils-r1_src_configure
-}