summaryrefslogtreecommitdiff
path: root/dev-python/pyvirtualdisplay
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/pyvirtualdisplay
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/pyvirtualdisplay')
-rw-r--r--dev-python/pyvirtualdisplay/Manifest2
-rw-r--r--dev-python/pyvirtualdisplay/pyvirtualdisplay-2.2.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pyvirtualdisplay/Manifest b/dev-python/pyvirtualdisplay/Manifest
index ed7dcd48a86e..741e97943c5d 100644
--- a/dev-python/pyvirtualdisplay/Manifest
+++ b/dev-python/pyvirtualdisplay/Manifest
@@ -1,3 +1,5 @@
DIST PyVirtualDisplay-2.1.tar.gz 40798 BLAKE2B 315bb794b81948357919e98637b6276cca11739d019333c873a2b9c3d28d0bbece6996a70fe619f7acae658bcbaa2743dbbdfb23b7b8515c3a40858a83b07712 SHA512 f95a1622adfa1198d7f35757110e923e45bbfc18b31945c9efedb578e1a27fc91ffec403cc68269b2414837260b2b56ae9a58323ed5020af962757722d7a4517
+DIST PyVirtualDisplay-2.2.tar.gz 40882 BLAKE2B 8fb2227928c8475994e4e54a42dada2b1921678adcec562d9658e01edc0e356aea714cc9a507c93be66d9c61dceeaadde4f22cc636504f4403e985ac2df96248 SHA512 33567d12fc63359869e4baa2413794e9caacd147a5b6ffe2ca79e1292f6174ff7e04371fac5737002fccc6654d0a5dd44907fac774b666ca10588185c5c5f7cc
EBUILD pyvirtualdisplay-2.1.ebuild 1130 BLAKE2B e09b3b90e6867f9a31738696ea25bf50e341e7f076dcd045b1eb686df36e1c3b0c432636f5f56517472c28298f6b58dd5d9c2650beb66d8af2ef868a30dfa6c4 SHA512 dee845a6a462ba14b0c2091f616a3928522f58b613d86b3f254d931eba196f654d039c62888eb2a3c0263269319776450fb89309b3ae22c8b1115f032b9dcd6a
+EBUILD pyvirtualdisplay-2.2.ebuild 1133 BLAKE2B b8c5b468a7516728da6f0bb9d6b6b4628a4852b6f65483a6b85912c286d7cc8f66d3714c25a81ab1094a6f4e75e45f2688ec75a06dd43db424e75898171a46e7 SHA512 5c8d43fac9b06b697db7374e09e34ed11ac4ea4f83d1de6eeaf1771bc97c6f44bbac9ca1ee262238098b7bb1d671850eecba44f127866422232246505962a5a7
MISC metadata.xml 462 BLAKE2B f073d91b8a3d4abe16621a1f22c7e00b650dfb74ffe5685803c2b1dd828d1f4cf7f182b008077daceb7bb43ba740901b5edfc8b2c5b8dcb6509ef6eb670348d2 SHA512 4c68e76fbddc9f6d840287dc38c5c869c6c258f160dcb684da50d0bb7749f0ed3580e638eb5b4a6c2fc38b66909afe0d502fde0a9799e0ef362016e8429a2451
diff --git a/dev-python/pyvirtualdisplay/pyvirtualdisplay-2.2.ebuild b/dev-python/pyvirtualdisplay/pyvirtualdisplay-2.2.ebuild
new file mode 100644
index 000000000000..e61794a73854
--- /dev/null
+++ b/dev-python/pyvirtualdisplay/pyvirtualdisplay-2.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+MY_P=PyVirtualDisplay-${PV}
+DESCRIPTION="Python wrapper for Xvfb, Xephyr and Xvnc"
+HOMEPAGE="https://github.com/ponty/PyVirtualDisplay"
+SRC_URI="
+ https://github.com/ponty/PyVirtualDisplay/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# pyvirtualdisplay.smartdisplay.DisplayTimeoutError: Timeout! elapsed time:60.3 timeout:60
+# tests hang in xvfb
+RESTRICT="test"
+
+RDEPEND="dev-python/easyprocess[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep \
+ 'dev-python/backports-tempfile[${PYTHON_USEDEP}]' python3_7 python3_8 )
+ dev-python/entrypoint2[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyscreenshot[${PYTHON_USEDEP}]
+ ~dev-python/vncdotool-0.13.0[${PYTHON_USEDEP}]
+ x11-apps/xmessage
+ x11-base/xorg-server[xvfb,xephyr]
+ x11-misc/x11vnc
+ )"
+
+distutils_enable_tests pytest