summaryrefslogtreecommitdiff
path: root/dev-python/pywavelets/pywavelets-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/pywavelets/pywavelets-1.1.1.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/pywavelets/pywavelets-1.1.1.ebuild')
-rw-r--r--dev-python/pywavelets/pywavelets-1.1.1.ebuild20
1 files changed, 7 insertions, 13 deletions
diff --git a/dev-python/pywavelets/pywavelets-1.1.1.ebuild b/dev-python/pywavelets/pywavelets-1.1.1.ebuild
index ac3571d385b5..1852f244e8be 100644
--- a/dev-python/pywavelets/pywavelets-1.1.1.ebuild
+++ b/dev-python/pywavelets/pywavelets-1.1.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -14,15 +14,14 @@ DESCRIPTION="Discrete Wavelet Transforms in Python"
HOMEPAGE="https://pywavelets.readthedocs.io/en/latest/
https://github.com/PyWavelets/pywt"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
+IUSE="examples"
RDEPEND="
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}] )
dev-python/matplotlib[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
"
@@ -31,19 +30,14 @@ BDEPEND="${RDEPEND}
"
distutils_enable_tests pytest
-
-S="${WORKDIR}/${MY_P}"
+distutils_enable_sphinx doc/source \
+ dev-python/numpydoc
python_test() {
- pytest -vv --pyargs ${BUILD_DIR}"/lib" || die "Tests fail with ${EPYTHON}"
-}
-
-python_compile_all() {
- use doc && emake -C doc html
+ epytest --pyargs ${BUILD_DIR}"/lib"
}
python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
distutils-r1_python_install_all
if use examples; then
docinto examples