summaryrefslogtreecommitdiff
path: root/dev-python/pywayland/pywayland-0.4.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-02 10:15:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-02 10:15:56 +0100
commit15bd3dfb22c7ba23dad0823e326dbcb8bb31b892 (patch)
tree6da8c6fe191bb632a2a6454968d2d1cc1338a5dc /dev-python/pywayland/pywayland-0.4.15.ebuild
parentec82846d15c127f36a0f0620e30c9c0fbbdd514c (diff)
gentoo auto-resync : 02:09:2023 - 10:15:56
Diffstat (limited to 'dev-python/pywayland/pywayland-0.4.15.ebuild')
-rw-r--r--dev-python/pywayland/pywayland-0.4.15.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/pywayland/pywayland-0.4.15.ebuild b/dev-python/pywayland/pywayland-0.4.15.ebuild
deleted file mode 100644
index 13737fa80279..000000000000
--- a/dev-python/pywayland/pywayland-0.4.15.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} pypy3 )
-
-inherit distutils-r1 xdg-utils
-
-DESCRIPTION="Python bindings for the libwayland library"
-HOMEPAGE="
- https://pywayland.readthedocs.io/en/latest/
- https://github.com/flacjacket/pywayland
- https://pypi.org/project/pywayland/
-"
-SRC_URI="
- https://github.com/flacjacket/pywayland/archive/refs/tags/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~riscv ~x86"
-
-RDEPEND="
- dev-libs/wayland
- $(python_gen_cond_dep '
- dev-python/cffi[${PYTHON_USEDEP}]
- ' 'python*')
-"
-DEPEND="
- ${RDEPEND}
- dev-libs/wayland-protocols
-"
-BDEPEND="
- dev-util/wayland-scanner
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Needed for tests (XDG_RUNTIME_DIR)
- xdg_environment_reset
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # No die deliberately as sometimes it doesn't exist
- rm -rf pywayland || die
-
- epytest
-}