summaryrefslogtreecommitdiff
path: root/dev-python/pywayland/pywayland-0.4.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-07 12:00:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-07 12:00:01 +0100
commita519cf56a0e5e456006d39c06f68de5e11c2f7e9 (patch)
treeeb3511664a62de4a02ec7f25a9a3935956e288ab /dev-python/pywayland/pywayland-0.4.17.ebuild
parentd63d16d19ab9b58260753953a431d39230f2c362 (diff)
gentoo auto-resync : 07:10:2023 - 12:00:01
Diffstat (limited to 'dev-python/pywayland/pywayland-0.4.17.ebuild')
-rw-r--r--dev-python/pywayland/pywayland-0.4.17.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pywayland/pywayland-0.4.17.ebuild b/dev-python/pywayland/pywayland-0.4.17.ebuild
new file mode 100644
index 000000000000..3741622e025e
--- /dev/null
+++ b/dev-python/pywayland/pywayland-0.4.17.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Python bindings for the libwayland library"
+HOMEPAGE="
+ https://pywayland.readthedocs.io/en/latest/
+ https://github.com/flacjacket/pywayland
+ https://pypi.org/project/pywayland/
+"
+SRC_URI="
+ https://github.com/flacjacket/pywayland/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/wayland
+ $(python_gen_cond_dep '
+ dev-python/cffi[${PYTHON_USEDEP}]
+ ' 'python*')
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ dev-util/wayland-scanner
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Needed for tests (XDG_RUNTIME_DIR)
+ xdg_environment_reset
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # No die deliberately as sometimes it doesn't exist
+ rm -rf pywayland || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}