summaryrefslogtreecommitdiff
path: root/dev-python/pywinrm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /dev-python/pywinrm
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'dev-python/pywinrm')
-rw-r--r--dev-python/pywinrm/Manifest3
-rw-r--r--dev-python/pywinrm/metadata.xml12
-rw-r--r--dev-python/pywinrm/pywinrm-0.3.0.ebuild25
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pywinrm/Manifest b/dev-python/pywinrm/Manifest
new file mode 100644
index 000000000000..3fbccf70cdd3
--- /dev/null
+++ b/dev-python/pywinrm/Manifest
@@ -0,0 +1,3 @@
+DIST pywinrm-0.3.0.tar.gz 25175 BLAKE2B bf020a2343dd317234d52600425930c9e8a798d07443f33279950d011c23ecffef97eb10042f4453ca8062d163c75c694d04b1e1f9facc3a6fe1da8d6840671d SHA512 4a6ec3e5cc4b9030275454d846fa4356f444481fe798f013f2be4dbfd4974f11ab2ccaabbc749f6e64fda985324ce6ffb1af906cdca02d2e2cb606d10bb94d02
+EBUILD pywinrm-0.3.0.ebuild 698 BLAKE2B 31a8957923e870a8e8231536ff53f42035cc3d1d2dc0abf02c80566c2cbbdb14515c09e1c79e7d8e143ff357ecc2c69dd0357c283188cc695576384e65944f8e SHA512 5c93817548faa0e225b2c3c56b68a20732ef1692927347baacc95947fad7abd7f7d7d985e1d14f266e45374c267bcb5c56e7d6dbe20c6ce46cadd26b35f6833d
+MISC metadata.xml 316 BLAKE2B 303bc2b58c8edb651c2dde7610eb874282223fa0b786208f488b9f1f82fd6fd63ead38e561cd46d65ab9ad189e261ae226a0ea8f0e99cded18d08dfa32bf37d0 SHA512 8d18f71c55b50755a61086ce593cb81f1095b35ee6e423da418f0e652e1842c6025bed1af48115c2847808deea4d1137d0bd70dfbb4c4f1c9fd720c14a54a415
diff --git a/dev-python/pywinrm/metadata.xml b/dev-python/pywinrm/metadata.xml
new file mode 100644
index 000000000000..4091bd7dda62
--- /dev/null
+++ b/dev-python/pywinrm/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="pypi">pywinrm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pywinrm/pywinrm-0.3.0.ebuild b/dev-python/pywinrm/pywinrm-0.3.0.ebuild
new file mode 100644
index 000000000000..7fc926f49b0c
--- /dev/null
+++ b/dev-python/pywinrm/pywinrm-0.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Windows Remote Management through Python"
+HOMEPAGE="https://pypi.org/project/pywinrm/"
+SRC_URI="mirror://pypi/p/pywinrm/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-credssp[${PYTHON_USEDEP}]
+ dev-python/requests-kerberos[${PYTHON_USEDEP}]
+ dev-python/requests-ntlm[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"