summaryrefslogtreecommitdiff
path: root/dev-python/pywlroots/pywlroots-0.16.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-15 22:00:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-15 22:00:32 +0100
commit4fe36de7142d972c061813e413f66ed4bcfc38d0 (patch)
treef95577c134cc26bf3d7223b38b8c76311d57fc12 /dev-python/pywlroots/pywlroots-0.16.4-r1.ebuild
parent2e4d96d87e04d8b2164f764dee727cd9057cf88d (diff)
gentoo auto-resync : 15:10:2023 - 22:00:32
Diffstat (limited to 'dev-python/pywlroots/pywlroots-0.16.4-r1.ebuild')
-rw-r--r--dev-python/pywlroots/pywlroots-0.16.4-r1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/pywlroots/pywlroots-0.16.4-r1.ebuild b/dev-python/pywlroots/pywlroots-0.16.4-r1.ebuild
deleted file mode 100644
index 2383e3084456..000000000000
--- a/dev-python/pywlroots/pywlroots-0.16.4-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python binding to the wlroots library using cffi"
-HOMEPAGE="
- https://github.com/flacjacket/pywlroots/
- https://pypi.org/project/pywlroots/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~riscv ~x86"
-
-# See README for wlroots dep
-DEPEND="
- $(python_gen_cond_dep '
- dev-python/cffi[${PYTHON_USEDEP}]
- ' 'python*')
- >=dev-python/pywayland-0.4.14[${PYTHON_USEDEP}]
- >=dev-python/xkbcommon-0.2[${PYTHON_USEDEP}]
- =gui-libs/wlroots-$(ver_cut 1-2)*:=
- x11-base/xwayland
-"
-RDEPEND="
- ${DEPEND}
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.15.24-no-import-version-check.patch
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- rm -rf wlroots || die
- epytest
-}