summaryrefslogtreecommitdiff
path: root/dev-python/pyxdg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-22 14:25:03 +0100
commit5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (patch)
treeb041acef19bb9ae66c228d5c9d34d1e00aeb2b95 /dev-python/pyxdg
parent5cfef3c94cd7e82136c69a0322f5ba21f7e64632 (diff)
gentoo resync : 22.04.2018
Diffstat (limited to 'dev-python/pyxdg')
-rw-r--r--dev-python/pyxdg/Manifest2
-rw-r--r--dev-python/pyxdg/pyxdg-0.26.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyxdg/Manifest b/dev-python/pyxdg/Manifest
index 1241b4ae0fbd..590870d34d4d 100644
--- a/dev-python/pyxdg/Manifest
+++ b/dev-python/pyxdg/Manifest
@@ -1,4 +1,6 @@
AUX sec-patch-CVE-2014-1624.patch 1867 BLAKE2B 7345af45e863876b9c0f11c0dedb2dc124e53448c532bcf622f085e3a4c3040c9308352414e173c6adf74cb1c55efaac1824bb99fc8013f63dc8cfd3610989ea SHA512 f0ff5255108b7a5774d376a8892f1120f5056ec92fa543af7e5aabe3792e7ecd347ac78ff5c04ab36db35bba513a412f6aa06fe718933317a903264bd184b712
DIST pyxdg-0.25.tar.gz 48935 BLAKE2B 8feffefff37da1e560040b36cc1ccb4ffdc57642b4de92f7a937303a02117ffe263a5dfc91bb6e85112ce60bc19509c21e7f8f859ef3ca5fca0e8c87a61cb128 SHA512 86cbf3a54fb8e79043db60dcdbb3fb10013ae25a900fa3592edc8a24bf3f440c19bc04626c7906293c785fcb56eab9d87d209b723b5baa872376ba1eb86758b6
+DIST pyxdg-rel-0.26.tar.gz 68435 BLAKE2B a95948db17da9909554e82c0ccf590c3f94ec26d1e34d5ba335868233a649368c08ef30cc19e878310ef038e5bdb6d18cd0e15e9413d9c54b70931f25844ee8c SHA512 0c11bccb74b8c0d98f3c63c318d35d08e1c3bbea128bf7b82792e1bdc0a60c8c4d6414b0612b19296cfb48f7951dfc6dd55ac8d23238e370e7faf6c4f64d1fb6
EBUILD pyxdg-0.25-r1.ebuild 755 BLAKE2B 15a48e50dce7a5e0e35c4f6e4e4c56ab62db05c5d685b067935fcd1f7a9f616945e75ff8fa9945041c50a99bf4a242e5443eca316f499f79df9f0e31a0e3376a SHA512 f4f92b92d43107ea6d2aad282683b001db8b89d5747a9dcd33ac81b1eb908ab755f70d7484094bc455c578b07798fd149875675fda5e380918182d3653df536f
+EBUILD pyxdg-0.26.ebuild 778 BLAKE2B 73b062df847ecc66d843f28e1106db6058288c4d5a56283f1f1fcfa150d4692da5cf9b73920e4b1a16a409081c33dd2f25bc9621ae683c660a1729510b75b315 SHA512 ac13b58a958ca4c57b01c019b265b018440f6a05cfe43b347bb0422d3f1b101415fed50104b6b2b313670a1cdcd1a2027fb6f1192acf3c0f32fd96fc87cd4112
MISC metadata.xml 487 BLAKE2B 4967a9b3c1a439c3cc53208ad2095031b08c4848ade6f2bb08a69aedbef5f5046f28764db62bcf3cac4c1c33c68958a7d2aba03a3b4cb7b7a407e41eddfec5f1 SHA512 f00421023d46b9aa32d8038c5ba8bfdb1b60a732932d64f7d11fe6f0c163b734182e2162dde2ba663d7c74ba8c754ece721dfbfa0b8fa3081be622dfff3949ea
diff --git a/dev-python/pyxdg/pyxdg-0.26.ebuild b/dev-python/pyxdg/pyxdg-0.26.ebuild
new file mode 100644
index 000000000000..865cf22122e7
--- /dev/null
+++ b/dev-python/pyxdg/pyxdg-0.26.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+inherit distutils-r1
+
+MY_P=${PN}-rel-${PV}
+DESCRIPTION="A Python module to deal with freedesktop.org specifications"
+HOMEPAGE="https://freedesktop.org/wiki/Software/pyxdg https://cgit.freedesktop.org/xdg/pyxdg/"
+# official mirror of the git repo
+SRC_URI="https://github.com/takluyver/pyxdg/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ x11-themes/hicolor-icon-theme
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ nosetests -v || die
+}