summaryrefslogtreecommitdiff
path: root/dev-python/pyzmq
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-31 22:43:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-31 22:43:14 +0000
commit7323114f21150e9c3714584386134160e2c520cf (patch)
treeb361bee15d0d87cf243bdf778fdfff9e8d7256a8 /dev-python/pyzmq
parent4856d9d89d9f533d36c415521ddc9c23be3c6033 (diff)
gentoo auto-resync : 31:01:2025 - 22:43:14
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/Manifest2
-rw-r--r--dev-python/pyzmq/pyzmq-26.2.1.ebuild87
2 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index 8689123a09b9..f6e0b80c0c84 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -1,3 +1,5 @@
DIST pyzmq-26.2.0.gh.tar.gz 272883 BLAKE2B a43365afdc49ae845f1e6611bd463e90dbd133867d82c2bfdd3d9431238f68d80bb8073a4406110a91bf6f72cc6d66987a477673277c2b099d74c78f24b49d81 SHA512 ef069f5e71ad1cd39fdf4d5c2ede411752685af2d69ea8ad477c70e51ab011ece492ab25d06feefa7b7c7daefc5fc822d0f87199df2216865ece254c5724c423
+DIST pyzmq-26.2.1.gh.tar.gz 279826 BLAKE2B 72ad282e8fd93f8ea9e3f709d748fd89a2a93e4af0f69d807b78654617195fb9b99646084747c617d1648c7ce0da55d01f2cd283eafa86e834df0a97ad578a7f SHA512 d68f8769ebb57e54eb405f9e8a6dda0cef8be912288c1cc9addaf6cd952f1b95029049f8c9300d05abb592b234fdb147f29e4430f1624132bda868b8a3ec8a20
EBUILD pyzmq-26.2.0.ebuild 2103 BLAKE2B d61161d7614b020f18d1089b1ac1ec22495d0dbed6d1f866c39f1228898a84d09bd61c550eb5e4fec2328bded17f8db3b2506e3e7dcb727b436bab00a48b6d49 SHA512 cf44b0689ea2f4b39636125814b9094d39bbb97ceb6df7ca1b4839ac547c5e4e78834716a58f10cccd99199e96c351194ca064140d6b962609bc89628220ab84
+EBUILD pyzmq-26.2.1.ebuild 2111 BLAKE2B c3414768b71c63021aad0e872db86ed746a0707ca2cc4e126dc8f8d3ce637472f372151e2529a0390e5263e21fff6f45e92aee6d5dbf6a2c46d2ad080b9de42c SHA512 7bf67e790ea168dc002046bd00347767325c10a79f2446ed4faf15e6f31143c9a5b6cb044e04d9bd0b31854e155a8947d4efd9be8f203eda27a4f8e4ae8731bd
MISC metadata.xml 536 BLAKE2B da6bb83977b50c7d62d288eb36890eae8203b31fe943c7159519fbba3a489aa5be94f6eccb150dc21d24e01988e8862cbb1b8f51cf5b47f3564a00d16ef19335 SHA512 9ddef2906564fae6aaff83a6aa00b47da207220f46a3f7618496fdb7cdf68e522bcd89587327735568a4ec82d533f8e9f6db499c7c634be182492de5660c3b05
diff --git a/dev-python/pyzmq/pyzmq-26.2.1.ebuild b/dev-python/pyzmq/pyzmq-26.2.1.ebuild
new file mode 100644
index 000000000000..469a00935119
--- /dev/null
+++ b/dev-python/pyzmq/pyzmq-26.2.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=scikit-build-core
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
+HOMEPAGE="
+ https://zeromq.org/languages/python/
+ https://pypi.org/project/pyzmq/
+ https://github.com/zeromq/pyzmq/
+"
+SRC_URI="
+ https://github.com/zeromq/pyzmq/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~x64-macos"
+IUSE="drafts"
+
+# There are additional test failures if zeromq has the draft api enabled, but pyzmq has it disabled.
+DEPEND="
+ >=net-libs/zeromq-4.2.2-r2:=[drafts=]
+"
+# It uses cffi backend for pypy, cython backend for cpython
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/cython-3.0.0[${PYTHON_USEDEP}]
+ ' 'python*')
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ >=dev-python/tornado-5.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO: Package enum_tools
+# distutils_enable_sphinx docs/source \
+# dev-python/numpydoc \
+# dev-python/sphinx-rtd-theme \
+# dev-python/myst-parser
+
+src_configure() {
+ DISTUTILS_ARGS=(
+ -DZMQ_DRAFT_API="$(usex drafts)"
+ -DPYZMQ_NO_BUNDLE=ON
+ # unnecessarily adds /usr/lib* to rpath
+ -DPYZMQ_LIBZMQ_RPATH=OFF
+ )
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # often crashes zmq?
+ tests/test_log.py::TestPubLog
+ )
+ local EPYTEST_IGNORE=(
+ # Avoid dependency on mypy
+ tests/test_mypy.py
+ )
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # not implemented in cffi variant?
+ tests/test_draft.py::TestDraftSockets
+ )
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ rm -rf zmq || die
+ # avoid large to reduce memory consumption
+ epytest -p asyncio -p rerunfailures tests -m "not large"
+}