summaryrefslogtreecommitdiff
path: root/dev-python/qdarkstyle/qdarkstyle-3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-26 20:41:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-26 20:41:49 +0100
commit12795ed0561fe52503d6aa3a1c60888553a03bd2 (patch)
treebebc6554f117bd11f5e1c3503ed66966afcb5f3f /dev-python/qdarkstyle/qdarkstyle-3.1.ebuild
parent7e8f2c69a019131eaeb989242d022260ea5a84ff (diff)
gentoo auto-resync : 26:10:2023 - 20:41:49
Diffstat (limited to 'dev-python/qdarkstyle/qdarkstyle-3.1.ebuild')
-rw-r--r--dev-python/qdarkstyle/qdarkstyle-3.1.ebuild29
1 files changed, 20 insertions, 9 deletions
diff --git a/dev-python/qdarkstyle/qdarkstyle-3.1.ebuild b/dev-python/qdarkstyle/qdarkstyle-3.1.ebuild
index 1ef2f4f8a6d1..36689ad9eeb0 100644
--- a/dev-python/qdarkstyle/qdarkstyle-3.1.ebuild
+++ b/dev-python/qdarkstyle/qdarkstyle-3.1.ebuild
@@ -3,30 +3,41 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYPI_PN="QDarkStyle"
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 optfeature pypi
DESCRIPTION="A dark style sheet for QtWidgets application"
-HOMEPAGE="https://github.com/ColinDuquesnoy/QDarkStyleSheet"
+HOMEPAGE="
+ https://github.com/ColinDuquesnoy/QDarkStyleSheet/
+ https://pypi.org/project/QDarkStyle/
+"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
-RDEPEND=">=dev-python/QtPy-1.9[gui,${PYTHON_USEDEP}]"
-
-DEPEND="test? (
- dev-python/qtsass[${PYTHON_USEDEP}]
- dev-python/watchdog[${PYTHON_USEDEP}]
- >=dev-python/QtPy-1.9[gui,testlib,${PYTHON_USEDEP}]
-)"
+RDEPEND="
+ >=dev-python/QtPy-1.9[gui,${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/qtsass[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-1.9[gui,testlib,${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
pkg_postinst() {
optfeature "Retrieve detailed system information and report bugs upstream" dev-python/helpdev
optfeature "qdarkstyle.utils" dev-python/qtsass dev-python/watchdog