summaryrefslogtreecommitdiff
path: root/dev-python/qiskit-aer/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-10 12:04:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-10 12:04:40 +0000
commitf95eeaf7db6ca1bfbb34c05fdad9ed9bb603b1c8 (patch)
tree1648438f1ddf9c11ea7cc5f7825a8d19266f00a5 /dev-python/qiskit-aer/files
parent27ecae7b5eb4c80903720ae76a54a68af3447c31 (diff)
gentoo auto-resync : 10:03:2023 - 12:04:40
Diffstat (limited to 'dev-python/qiskit-aer/files')
-rw-r--r--dev-python/qiskit-aer/files/qiskit-aer-0.12.0-remove-cmake-dependency.patch13
-rw-r--r--dev-python/qiskit-aer/files/qiskit-aer-0.12.0-wheel-dep.patch22
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/qiskit-aer/files/qiskit-aer-0.12.0-remove-cmake-dependency.patch b/dev-python/qiskit-aer/files/qiskit-aer-0.12.0-remove-cmake-dependency.patch
new file mode 100644
index 000000000000..d54e1993a7ea
--- /dev/null
+++ b/dev-python/qiskit-aer/files/qiskit-aer-0.12.0-remove-cmake-dependency.patch
@@ -0,0 +1,13 @@
+diff --git a/pyproject.toml b/pyproject.toml
+index 0e025a3..566aa44 100644
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -4,8 +4,6 @@ requires = [
+ "wheel",
+ "conan<2.0.0",
+ "scikit-build>=0.11.0",
+- "cmake!=3.17.1,!=3.17.0",
+- "ninja",
+ "pybind11>2.6",
+ "oldest-supported-numpy; python_version>'3.7' or platform_machine=='aarch64' or platform_python_implementation=='PyPy'",
+ "numpy==1.16.3; python_version<='3.7' and platform_machine!='aarch64' or platform_python_implementation=='PyPy'",
diff --git a/dev-python/qiskit-aer/files/qiskit-aer-0.12.0-wheel-dep.patch b/dev-python/qiskit-aer/files/qiskit-aer-0.12.0-wheel-dep.patch
new file mode 100644
index 000000000000..49645db8626d
--- /dev/null
+++ b/dev-python/qiskit-aer/files/qiskit-aer-0.12.0-wheel-dep.patch
@@ -0,0 +1,22 @@
+https://github.com/Qiskit/qiskit-aer/pull/1741
+
+From 5bf744a9fc033aee2eb448e2595f8e35734982e3 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Fri, 10 Mar 2023 04:56:34 +0000
+Subject: [PATCH] Remove redundant wheel dep from pyproject.toml
+
+Remove the redundant `wheel` dependency, as it is added by the backend automatically.
+
+Listing it explicitly in the documentation was a historical mistake and has been fixed since,
+see: [pypa/setuptools@f7d30a9](https://github.com/pypa/setuptools/commit/f7d30a9529378cf69054b5176249e5457aaf640a).
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,7 +1,6 @@
+ [build-system]
+ requires = [
+ "setuptools",
+- "wheel",
+ "conan<2.0.0",
+ "scikit-build>=0.11.0",
+ "cmake!=3.17.1,!=3.17.0",
+