summaryrefslogtreecommitdiff
path: root/dev-python/qiskit-aer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-24 14:56:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-24 14:56:08 +0100
commitc9b5a916efac64df2a39870a92cc6b67116d1b9f (patch)
tree126347f55a7e5eeddecc17d5a26886ffb11249f4 /dev-python/qiskit-aer
parentb818f6a820dceae80d6e3faac5fdf7be0c6fcbe2 (diff)
gentoo auto-resync : 24:08:2024 - 14:56:07
Diffstat (limited to 'dev-python/qiskit-aer')
-rw-r--r--dev-python/qiskit-aer/Manifest2
-rw-r--r--dev-python/qiskit-aer/qiskit-aer-0.15.ebuild119
2 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/qiskit-aer/Manifest b/dev-python/qiskit-aer/Manifest
index dae71214cc72..ff694ff00949 100644
--- a/dev-python/qiskit-aer/Manifest
+++ b/dev-python/qiskit-aer/Manifest
@@ -1,3 +1,5 @@
DIST qiskit-aer-0.14.2.gh.tar.gz 7132159 BLAKE2B bc684f7acca071866bc6413d5fb881cf131fe212be7294922a6861dc526d77d0cfb906d9c2ea57236e42e8a99e137ee0ac5f0c1e11fd027122983ad3d8992f73 SHA512 75a2fadb413fc557f98043cc028b28f6cae65b983fd0f32f1e8b8eda6d5cbc6d9d528c38f765d14ede5909045cef914335a483f762c20c4dd85754449d63371c
+DIST qiskit-aer-0.15.gh.tar.gz 7133462 BLAKE2B 3a72d5e1c97e54dd9090bbd072ca52c03bc90d53ec13bdb52b20112adebde6ef4e85a5d3761d5cc9fab7bc8d41651865e538eaad591dad266533441114ae1ddc SHA512 ce70755fa26150e8ce870a5f80c7f37a8e09f02ac4dbcfe52de2153b8af6f92764ac6866b1fffb75db6e1ae1b31815432ffca54f2f916337f640c14007a682f3
EBUILD qiskit-aer-0.14.2.ebuild 3631 BLAKE2B 93c158c8987377975049ecd1ae9af456f0b1fc39b7aedb1692b0aaddce5a142d26b9ff832af9c2012b1c6ba7dbf97194903bada56a17d51930d43a91b5c2f04a SHA512 6add6bc8b5eb9b26ae3e98660304420a0113dae3f6fbb6e571600188dd778284206a7a5b404d8a201c9400c15e25635efdfab2e0e4fa25ef98275fdc3b366746
+EBUILD qiskit-aer-0.15.ebuild 3631 BLAKE2B 93c158c8987377975049ecd1ae9af456f0b1fc39b7aedb1692b0aaddce5a142d26b9ff832af9c2012b1c6ba7dbf97194903bada56a17d51930d43a91b5c2f04a SHA512 6add6bc8b5eb9b26ae3e98660304420a0113dae3f6fbb6e571600188dd778284206a7a5b404d8a201c9400c15e25635efdfab2e0e4fa25ef98275fdc3b366746
MISC metadata.xml 1049 BLAKE2B e2118dc211ac8f42115959dde943a32331b4186524ef4a5a1343d8798a329e1d0de5f9a52a9c1212ec6af39392993378c6422424488782747ffbf4ab1e63d25e SHA512 bc4c9a19376938e973bedbdff0bbe95edb98c78b75d03f2a12985558a5cd5d0ceb934c43371438dd597a8d4fb8879d5483aeb8d806ac4d9b73b704d1232086b8
diff --git a/dev-python/qiskit-aer/qiskit-aer-0.15.ebuild b/dev-python/qiskit-aer/qiskit-aer-0.15.ebuild
new file mode 100644
index 000000000000..06def0bfe1d8
--- /dev/null
+++ b/dev-python/qiskit-aer/qiskit-aer-0.15.ebuild
@@ -0,0 +1,119 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="High performance simulator for quantum circuits that includes noise models"
+HOMEPAGE="
+ https://github.com/Qiskit/qiskit-aer/
+ https://pypi.org/project/qiskit-aer/
+"
+SRC_URI="
+ https://github.com/Qiskit/qiskit-aer/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# The reference implementation of BLAS/CBLAS is not compatible with qiskit-aer right now,
+# because importing library causes an error.
+# /usr/lib/python3.9/site-packages/qiskit/providers/aer/backends/controller_wrappers.cpython-39-x86_64-linux-gnu.so: undefined symbol: slamch_
+# Using sci-libs/openblas instead here,
+# with the option to switch between reference/openblas implementation runtime (eselect-ldso).
+#
+# <nlohmann_json-3.10.3 for https://github.com/Qiskit/qiskit-aer/issues/1742
+DEPEND="
+ >=dev-python/numpy-1.16.3[${PYTHON_USEDEP}]
+ <dev-cpp/nlohmann_json-3.10.3
+ >=dev-cpp/nlohmann_json-3.1.1
+ >=dev-libs/spdlog-1.9.2:=
+ >=dev-cpp/muParserX-4.0.8
+ virtual/cblas[eselect-ldso]
+ sci-libs/openblas[eselect-ldso]
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-python/psutil-5[${PYTHON_USEDEP}]
+ >=dev-python/qiskit-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-build/cmake-3.17
+ >=dev-python/scikit-build-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.6[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ddt[${PYTHON_USEDEP}]
+ dev-python/fixtures[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+check_openblas() {
+ local libdir=$(get_libdir) me="openblas"
+
+ # check blas
+ local current_blas=$(eselect blas show ${libdir} | cut -d' ' -f2)
+ if [[ ${current_blas} != "${me}" ]]; then
+ eerror "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
+ eerror "To use qiskit-aer, you have to issue (as root):"
+ eerror "\t eselect blas set ${libdir} ${me}"
+ return 1
+ fi
+ return 0
+}
+
+pkg_setup() {
+ if use test; then
+ check_openblas
+ if [[ $? -ne 0 ]]; then
+ die "Set blas implementation to openblas using 'eselect blas set openblas'!"
+ fi
+ fi
+}
+
+python_prepare_all() {
+ export DISABLE_CONAN="ON"
+ export DISABLE_DEPENDENCY_INSTALL="ON"
+ export SKBUILD_CONFIGURE_OPTIONS="-DTEST_JSON=1"
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires qiskit_qasm3_import
+ test/terra/backends/aer_simulator/test_save_statevector.py::TestSaveStatevector::test_save_statevector_for_qasm3_circuit_1___automatic____CPU__
+ test/terra/backends/aer_simulator/test_save_statevector.py::TestSaveStatevector::test_save_statevector_for_qasm3_circuit_2___statevector____CPU__
+ test/terra/backends/aer_simulator/test_save_statevector.py::TestSaveStatevector::test_save_statevector_for_qasm3_circuit_3___matrix_product_state____CPU__
+ test/terra/backends/aer_simulator/test_save_statevector.py::TestSaveStatevector::test_save_statevector_for_qasm3_circuit_4___extended_stabilizer____CPU__
+ )
+
+ local EPYTEST_IGNORE=(
+ # TODO: qiskit.providers.aer? wtf?
+ test/terra/expression/test_classical_expressions.py
+ )
+
+ # From tox.ini/tests.yml in CI
+ # Needed to suppress a warning in jupyter-core 5.x by eagerly migrating to
+ # a new internal interface that will be the default in jupyter-core 6.x.
+ # This variable should become redundant on release of jupyter-core 6.
+ local -x JUPYTER_PLATFORM_DIRS=1
+
+ rm -rf qiskit_aer || die
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -s
+}
+
+pkg_postinst() {
+ check_openblas
+}