summaryrefslogtreecommitdiff
path: root/dev-python/qstylizer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/qstylizer
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/qstylizer')
-rw-r--r--dev-python/qstylizer/Manifest3
-rw-r--r--dev-python/qstylizer/metadata.xml16
-rw-r--r--dev-python/qstylizer/qstylizer-0.1.10.ebuild52
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/qstylizer/Manifest b/dev-python/qstylizer/Manifest
new file mode 100644
index 000000000000..c8a177571335
--- /dev/null
+++ b/dev-python/qstylizer/Manifest
@@ -0,0 +1,3 @@
+DIST qstylizer-0.1.10.tar.gz 20683 BLAKE2B aa12addac6cbe1ebf043d70189683feda87db3a8c2aa3604a04a969f638647ba32eaf7d156559b8af151136aaca784f26025746d9f3e574ad6eb777801bcf44a SHA512 1a747c2a0d5ce0acd220f528bc54c84c723f50bf39fc8d818f6a5475105319f46700d2f00bc5c0f14de8f0caaee0ab8904a379a3e697ca68d00ef62ec3408b2b
+EBUILD qstylizer-0.1.10.ebuild 1532 BLAKE2B 8c9f1f9cde97d2a71d43229556faf80c541ea8852b2a75edc956aaa67847a2263731e27404744df61a164293dc84ad247fb11b2fb11ab9a210edb3c7c465087c SHA512 95e796722fa48eefcf6f4933621717c10ff15e000079efc014dd40d255518446ce030c326eb3f82fdefdc53457d13804610501f7500f3983278c1bf9fcd40a28
+MISC metadata.xml 501 BLAKE2B 6c537b7cb9a8447f4eff4bd559998b782969b9ecb147594f4f47c4cdd0eae7de2ae3fd195b257b4848f7c08f05cbef68832449684a409c58a6fa0ecd23a3bbec SHA512 e100e912e3ece0c01305b78fca2247e9927c5fe9d3b4d76c89eee5890ded4999894624a183e77714065f6d671a4ccbcf6fcd9fb9dd03a9e44f4125c848c300f2
diff --git a/dev-python/qstylizer/metadata.xml b/dev-python/qstylizer/metadata.xml
new file mode 100644
index 000000000000..4db1da22a045
--- /dev/null
+++ b/dev-python/qstylizer/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">qstylizer</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/qstylizer/qstylizer-0.1.10.ebuild b/dev-python/qstylizer/qstylizer-0.1.10.ebuild
new file mode 100644
index 000000000000..d6ea40554171
--- /dev/null
+++ b/dev-python/qstylizer/qstylizer-0.1.10.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Stylesheet Generator for PyQt5/PySide2"
+HOMEPAGE="https://github.com/blambright/qstylizer"
+SRC_URI="https://github.com/blambright/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/tinycss-0.4[${PYTHON_USEDEP}]
+ <dev-python/tinycss-1[${PYTHON_USEDEP}]
+ >=dev-python/inflection-0.3.0[${PYTHON_USEDEP}]
+ <dev-python/inflection-1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-vcs/git
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-autoprogram
+
+python_prepare_all(){
+ # Exception: Versioning for this project requires either an sdist tarball, or access to an
+ # upstream git repository. It's also possible that there is a mismatch between the package
+ # name in setup.cfg and the argument given to pbr.version.VersionInfo. Project name qstylizer
+ # was given, but was not able to be found.
+ #
+ # There are no tarballs on PyPI, so we do this as a workaround
+ git init || die
+ git config user.email "larry@gentoo.org" || die
+ git config user.name "Larry the Cow" || die
+ git add . || die
+ git commit -m "init" || die
+ git tag -a "${PV}" -m "${PV}" || die
+
+ distutils-r1_python_prepare_all
+}