summaryrefslogtreecommitdiff
path: root/dev-python/qstylizer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-05 16:24:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-05 16:24:39 +0100
commit4aec9255c99411cb07138353f1bdda61fe0b501d (patch)
tree034e5a94d1660a6fa13cec598dfb476647978e20 /dev-python/qstylizer
parenta0f09b2c947909b614c52fcfbdce964469404101 (diff)
gentoo auto-resync : 05:09:2022 - 16:24:39
Diffstat (limited to 'dev-python/qstylizer')
-rw-r--r--dev-python/qstylizer/Manifest2
-rw-r--r--dev-python/qstylizer/qstylizer-0.2.2.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/qstylizer/Manifest b/dev-python/qstylizer/Manifest
index 90952e489911..14818ed6cf21 100644
--- a/dev-python/qstylizer/Manifest
+++ b/dev-python/qstylizer/Manifest
@@ -1,3 +1,5 @@
DIST qstylizer-0.2.1.tar.gz 20687 BLAKE2B ad158ac0f88c4a0a7c6d9fe9adc611f69cb946c28be8c414dbb40532901b53faee281e7c0a798c9f680d8e5cd8a04179b16df796041133a8dd65d117964e9905 SHA512 c5e4a4194b4282a6d2782c0636ed74e9885409570466765c6e2aee0a176175bb688854244828c56ffbd00e76d297a33de211dedae8d984021c816522ea2b6085
+DIST qstylizer-0.2.2.gh.tar.gz 20752 BLAKE2B c5442821389863bc03bb0659b528322cc12f5be8137f74746e3ec7a18bf89d2822d533d13cc23842daf32a0077ad84d0e7b5dc62f231e75e57388064bd08e5fc SHA512 682f10462965a93b36f0e44b75885b9d60b4d3cd03369976b977c9b928afed4e930b6b7ef26850bdb7b40ef2a31db35a9778738582dae8715f54c1f00a957fb3
EBUILD qstylizer-0.2.1-r1.ebuild 1569 BLAKE2B a142ea81c24235a68602ea7711ba47078fc1749fa7cb42c8562681c140f09cfd83ee74d93543f346c6ac6c438fa34d2e738fad0ffcd062a25cefc06e57905e50 SHA512 a0a382c0292119c8c684db0151a4615ac2a52ff213bcd8859e8be8ad19455959786d3efc11353dcbe039aebf43072932c05a34dd80823c2b85418dd109f48b51
+EBUILD qstylizer-0.2.2.ebuild 1572 BLAKE2B 2559416329605f75f6f38d23fa4f0f9869c88038233a68fd6703b9d85763de94065d4b865151b6efb1952de1d92ed5a769d9114147495eae7dc5ae4c6399e5eb SHA512 5902178ad1de4bece2dcb7191fdf868f606d9df1b619b9bd6940d0082b3d9d27fef9f2f49f1a4634df184601b4671c45007ebb782d4feb15a3a461d97247529c
MISC metadata.xml 355 BLAKE2B bbd0a92b969f24330e934a3fb9db82c99d4e0f4daeb6a4fadaa5cefa0caa2d4eab393f2743664ea7bf685df3deed81ffd3e4eb8f12089d395c4c6b231bec9d58 SHA512 504b904577a9f891df117d1ca79a0041463cef7fcadb8c2dbfcf2f88abf2c26bc08a976dff5d8e51a563d6a6070b354fa2c1918051aeccf3ea5a359a3ea04694
diff --git a/dev-python/qstylizer/qstylizer-0.2.2.ebuild b/dev-python/qstylizer/qstylizer-0.2.2.ebuild
new file mode 100644
index 000000000000..7e51a4b78757
--- /dev/null
+++ b/dev-python/qstylizer/qstylizer-0.2.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Stylesheet Generator for PyQt5/PySide2"
+HOMEPAGE="https://github.com/blambright/qstylizer"
+SRC_URI="https://github.com/blambright/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/tinycss2-0.5[${PYTHON_USEDEP}]
+ <dev-python/tinycss2-2[${PYTHON_USEDEP}]
+ >=dev-python/inflection-0.3.0[${PYTHON_USEDEP}]
+ <dev-python/inflection-1[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-vcs/git
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-autoprogram
+
+python_prepare_all() {
+ # Exception: Versioning for this project requires either an sdist tarball, or access to an
+ # upstream git repository. It's also possible that there is a mismatch between the package
+ # name in setup.cfg and the argument given to pbr.version.VersionInfo. Project name qstylizer
+ # was given, but was not able to be found.
+ #
+ # There are no tarballs on PyPI, so we do this as a workaround
+ git init -q || die
+ git config user.email "larry@gentoo.org" || die
+ git config user.name "Larry the Cow" || die
+ git add . || die
+ git commit -m "init" || die
+ git tag -a "${PV}" -m "${PV}" || die
+
+ distutils-r1_python_prepare_all
+}