summaryrefslogtreecommitdiff
path: root/dev-python/qtconsole
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-30 10:48:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-30 10:48:18 +0100
commit005a5b259b876973202153b9c5c5e77bea56df6c (patch)
tree62e787239ec670df6ea942997fd18c32f3879774 /dev-python/qtconsole
parent048bd060badd229e3bb596029874760a86d27060 (diff)
gentoo auto-resync : 30:08:2022 - 10:48:18
Diffstat (limited to 'dev-python/qtconsole')
-rw-r--r--dev-python/qtconsole/Manifest2
-rw-r--r--dev-python/qtconsole/qtconsole-5.3.2.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/qtconsole/Manifest b/dev-python/qtconsole/Manifest
index 28159f831dd5..35ec5d1b4dab 100644
--- a/dev-python/qtconsole/Manifest
+++ b/dev-python/qtconsole/Manifest
@@ -1,3 +1,5 @@
DIST qtconsole-5.3.1.tar.gz 430680 BLAKE2B 4655d9aa78a95200fb3f4d2016749d4f1c75865d259da8583818259d05301469b9851b85a2716336084f022f546e97ae003483284f0305793da80a5de7635ac2 SHA512 bebf9c97ebe2a030feebd34f9dbc83294af5eb64946b252c5b5e6391e2760ff95efa7f0be89ec59c424de5fefb3f876ead897d17b679fc87896fe440ba936554
+DIST qtconsole-5.3.2.tar.gz 430792 BLAKE2B 246dadaab92851f8da65dfa4c7e80390defeb0855fdb3ea5ef6aab96bf56b28597dc65d7cb4fc95f0f795a19f4b826d0ec1e1e0b025f4fa49d4d5a78473a2b29 SHA512 715e7e4b185a656f395a30c575e8996271cea4672871d9471c74a13364be1ef0fe0e63951e8f52f10b9c887592dc899c399ae82e09f9934492d13119b1154796
EBUILD qtconsole-5.3.1.ebuild 1593 BLAKE2B 34ba6800a4d3fead61d6fd3519c0f861dee511cf9ffe47e6396585977163a2992f0d8d59525c20ce99db0edcd387cad79d8d268aa55a29c91965970fdaa8fa36 SHA512 5ef7817012f6dbcec0443b3c8671a513fc90e6ef8dd1b8117106c545cfe70f88948dac35242b563b302fd4a6a013bcea89923c35be047dd3594eaf1c87d8bbf5
+EBUILD qtconsole-5.3.2.ebuild 1596 BLAKE2B 69ca074939f73968844e15e996ebee3dce514f72a6b24e473f03dc4588a96633400616b9d5adb63381b64bbdd4ef35342ea7114b03540e1d7ad4135075c7de57 SHA512 04f3dab235e5e9344cee88abf5298e15bf5253fdfed14ec1ba9d440a3c81c3fe58329a007de44ad27dc71451f158410156a57536152f74351ffaeaac490ee658
MISC metadata.xml 690 BLAKE2B f2ddc6515f66ac4549e99bd6f152c16431875508bf12b6319e0e6a2b1596d86abc50b87ee424d3876eb55e92d1a506ade6567cbad535b4b2b54fad924a1891a7 SHA512 28bb7360ac7775d9c72c4d0f34d4c9a35c63905c4e870722236cc6c66e98f6c0eb165c8d7a9ce28948b25808a053dd1bb667d1f4783ca95319bb216310dc9f60
diff --git a/dev-python/qtconsole/qtconsole-5.3.2.ebuild b/dev-python/qtconsole/qtconsole-5.3.2.ebuild
new file mode 100644
index 000000000000..e065753cbc2d
--- /dev/null
+++ b/dev-python/qtconsole/qtconsole-5.3.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/qtconsole/
+ https://pypi.org/project/qtconsole/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.1[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-4.1.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.2.2_p1[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-2.0.1[${PYTHON_USEDEP},gui,printsupport,svg]
+"
+# The test suite tests both against pyqt5 *and* pyside2
+BDEPEND="
+ test? (
+ dev-python/QtPy[pyqt5,pyside2,${PYTHON_USEDEP},svg,testlib]
+ )
+"
+# required by the tests that are removed:
+# dev-python/flaky[${PYTHON_USEDEP}]
+# dev-python/pytest-qt[${PYTHON_USEDEP}]
+
+PDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_test() {
+ # TODO: these tests require virtx; however, running under virtx
+ # causes pytest to segv on exit (even though tests pass)
+ EPYTEST_IGNORE=(
+ qtconsole/tests/test_00_console_widget.py
+ qtconsole/tests/test_jupyter_widget.py
+ )
+ epytest
+}