summaryrefslogtreecommitdiff
path: root/dev-python/qtpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-21 06:30:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-21 06:30:52 +0000
commitd2bcdab82e5f5f38a8ab54026e8aa94edb1b77a6 (patch)
tree0d75edaef0b7c0db490d25119f6b17b386d41c58 /dev-python/qtpy
parent9097a9c06c0b1e11c7f6579f03e3f32948be3f24 (diff)
gentoo auto-resync : 21:12:2024 - 06:30:51
Diffstat (limited to 'dev-python/qtpy')
-rw-r--r--dev-python/qtpy/Manifest3
-rw-r--r--dev-python/qtpy/metadata.xml5
-rw-r--r--dev-python/qtpy/qtpy-2.4.2-r1.ebuild186
3 files changed, 193 insertions, 1 deletions
diff --git a/dev-python/qtpy/Manifest b/dev-python/qtpy/Manifest
index 3dfc0dd2701c..8cf254785653 100644
--- a/dev-python/qtpy/Manifest
+++ b/dev-python/qtpy/Manifest
@@ -1,3 +1,4 @@
DIST qtpy-2.4.2.tar.gz 66849 BLAKE2B 1eb362e797950d6c1406fb02bb3047ca7f8fdecd2b75371ab34f39601c9bdebce33336e3809c0d35dca31673c88d1734721a6dfdfb65f2ce20729445c4a4ca27 SHA512 2f9a0e1a4839c8dca23b4364900a12c2bd00f518353785a41eb6bd62fdc469670457f18224e1150a5a216ff5d0c4e799c3a1711ff7703ea07fadd655538fa37a
+EBUILD qtpy-2.4.2-r1.ebuild 6291 BLAKE2B 4208e91b69d8fd9358832e05d974ed934c92c3ee8b8d642726867fea43ef96919badc9bc071482d9264313a4ace53bd94063a58e57ddc781460e134ab1ff5ac7 SHA512 149c2733e5fb7f78ae52945c0ced1f663f7e71d0b209db32d9fe6230eddfc047f4a39f0353920fbbb7fd15946f67ca72d45063b8422136143ab221544810cb70
EBUILD qtpy-2.4.2.ebuild 8778 BLAKE2B 53ddca392cd093ca6522b514b6e6b03259a8af310ed9e2b7018e46544c8efc04f86e5ced5658bd6914c1eff08bfe8564532077edacc4af6ccc50e3ba1d5a4695 SHA512 9625d427f78775355f9a749d31886e5b05627c2e7f2d852af3b20bdd106b543142b27047e7bcfa9f746e8c2a49839f57e4572f8c810cff18435315b7b35a6512
-MISC metadata.xml 2851 BLAKE2B c812a6a64662012c91334e57799c620164146abde81c120efda3db051ee102495b56cdbf325dac1f668ea50f83b2e928677b88722abb584dc31260b5a75ab067 SHA512 d4d4d0308d23811bff6c1784d0afc54d8df9d96c9397f0f2e49e04eff647fc1697474c2bb69b623a14ac39017e1d1ec292065c413bca1e029e4af818e65ce2f3
+MISC metadata.xml 3214 BLAKE2B 5228c6546721dfe06c488c6ab0edbfb14c2560bba1d35a70497193daec3b258ae08dce8efd9e29204dee2adadbacb94407311900406e2b216010c649ee6b5170 SHA512 25f882c68aabe5bf27e98c17a8708763df184a3931d7d0a47026ab016b13c46a84ce3f5e5a3964804e8083ff998d311ea38ab2ca52f38288e64a987ae0c54363
diff --git a/dev-python/qtpy/metadata.xml b/dev-python/qtpy/metadata.xml
index 6d647f05cf63..7feee8ad3488 100644
--- a/dev-python/qtpy/metadata.xml
+++ b/dev-python/qtpy/metadata.xml
@@ -24,13 +24,18 @@
<flag name="help">Pull in bindings for the QtHelp module</flag>
<flag name="multimedia">Pull in QtMultimedia and QtMultimediaWidgets modules</flag>
<flag name="network">Pull in bindings for the QtNetwork module</flag>
+ <flag name="nfc">Pull in bindings for the QtNFC module</flag>
<flag name="opengl">Pull in bindings for the QtOpenGL module</flag>
+ <flag name="pdfium">Pull in bindings for the QtPDFium module</flag>
<flag name="positioning">Pull in bindings for the QtPositioning module</flag>
<flag name="printsupport">Pull in bindings for the QtPrintSupport module</flag>
<flag name="qml">Build bindings for the QtQml</flag>
<flag name="quick">Build bindings for the QtQuick</flag>
+ <flag name="quick3d">Build bindings for the QtQuick3D</flag>
+ <flag name="remoteobjects">Pull in bindings for the QtRemoteObjects module</flag>
<flag name="sensors">Pull in bindings for the QtSensors module</flag>
<flag name="serialport">Pull in bindings for the QtSerialPort module</flag>
+ <flag name="spatialaudio">Pull in bindings for the QtSpatialAudio module</flag>
<flag name="speech">Pull in bindings for the QtTextToSpeech module</flag>
<flag name="sql">Pull in bindings for the QtSql module</flag>
<flag name="svg">Pull in bindings for the QtSvg module</flag>
diff --git a/dev-python/qtpy/qtpy-2.4.2-r1.ebuild b/dev-python/qtpy/qtpy-2.4.2-r1.ebuild
new file mode 100644
index 000000000000..41db84c47c11
--- /dev/null
+++ b/dev-python/qtpy/qtpy-2.4.2-r1.ebuild
@@ -0,0 +1,186 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN=QtPy
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 virtualx pypi
+
+DESCRIPTION="Abstraction layer on top of PyQt and PySide with additional custom QWidgets"
+HOMEPAGE="
+ https://github.com/spyder-ide/qtpy/
+ https://pypi.org/project/QtPy/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+_IUSE_QT_MODULES="
+ bluetooth dbus designer +gui help multimedia +network nfc opengl pdfium
+ positioning printsupport qml quick quick3d remoteobjects sensors serialport
+ spatialaudio speech +sql svg testlib webchannel webengine websockets
+ +widgets +xml
+"
+IUSE="+pyqt6 pyside6 ${_IUSE_QT_MODULES}"
+unset _IUSE_QT_MODULES
+
+REQUIRED_USE="|| ( pyqt6 pyside6 )"
+
+# These flags are currently *not* common to the PySide2/6 and PyQt5/6 ebuilds
+# Disable them for now, please check periodically if this is still up to date.
+# 3d? ( pyside6 only )
+# charts? ( pyside6 only )
+# concurrent? ( pyside6 only )
+# httpserver? ( pyside6 only )
+# scxml? ( pyside6 only )
+# uitools? ( pyside6 only )
+# location? ( pyside6 only)
+# network-auth? ( pyside6 only )
+#
+# vulkan? ( pyqt6 only )
+
+# WARNING: the obvious solution of using || for PyQt5/pyside2 is not going
+# to work. The package only checks whether PyQt5/pyside2 is installed, it does
+# not verify whether they have the necessary modules (i.e. satisfy the USE dep).
+#
+# Webengine is a special case, because PyQt6 provides this in a separate package
+# while PySide6 ships it in the same package.
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ pyqt6? (
+ dev-python/pyqt6[${PYTHON_USEDEP}]
+ dev-python/pyqt6[bluetooth?,dbus?,designer?,gui?,help?,multimedia?]
+ dev-python/pyqt6[network?,nfc?,opengl?,pdfium?,positioning?]
+ dev-python/pyqt6[printsupport?,qml?,quick?,quick3d?,remoteobjects?]
+ dev-python/pyqt6[sensors?,serialport?,spatialaudio?,speech?,sql?,svg?]
+ dev-python/pyqt6[testlib?,webchannel?,websockets?,widgets?,xml?]
+ webengine? ( dev-python/pyqt6-webengine[${PYTHON_USEDEP},widgets?,quick?] )
+
+ )
+ pyside6? (
+ dev-python/pyside6[${PYTHON_USEDEP}]
+ dev-python/pyside6[bluetooth?,dbus?,designer?,gui?,help?,multimedia?]
+ dev-python/pyside6[network?,nfc?,opengl?,pdfium?,positioning?]
+ dev-python/pyside6[printsupport?,qml?,quick?,quick3d?,remoteobjects(-)?]
+ dev-python/pyside6[sensors?,serialport?,spatialaudio?,speech?,sql?,svg?]
+ dev-python/pyside6[testlib?,webchannel?,webengine?,websockets?,widgets?,xml?]
+ )
+"
+
+# The QtPy testsuite skips tests for bindings that are not installed, so here we
+# ensure that everything is available and all tests are run. Note that not
+# all flags are available in PyQt5/PySide2, so some tests are still skipped.
+BDEPEND="
+ test? (
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+ pyqt6? (
+ dev-python/pyqt6[${PYTHON_USEDEP}]
+ dev-python/pyqt6[bluetooth,dbus,designer,gui,help,multimedia]
+ dev-python/pyqt6[network,nfc,opengl,pdfium,positioning,printsupport]
+ dev-python/pyqt6[qml,quick,quick3d,sensors,serialport]
+ dev-python/pyqt6[spatialaudio,speech,sql,svg,testlib,webchannel]
+ dev-python/pyqt6[vulkan(-),websockets,widgets,xml]
+ dev-python/pyqt6-webengine[${PYTHON_USEDEP},widgets,quick]
+ dev-qt/qtbase:6[sqlite]
+ )
+ pyside6? (
+ dev-python/pyside6[${PYTHON_USEDEP}]
+ dev-python/pyside6[3d,bluetooth,charts,concurrent,dbus,designer,gui]
+ dev-python/pyside6[help,location,multimedia,network,network-auth]
+ dev-python/pyside6[nfc,opengl,pdfium,positioning,printsupport,qml]
+ dev-python/pyside6[quick,quick3d,scxml,sensors,serialport]
+ dev-python/pyside6[spatialaudio,speech,sql,svg,testlib,webchannel]
+ dev-python/pyside6[webengine,websockets,widgets,xml]
+ dev-python/pyside6-tools[${PYTHON_USEDEP}]
+ dev-qt/qtbase:6[sqlite]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e 's:--cov=qtpy --cov-report=term-missing::' pytest.ini || die
+ # Disable Qt for Python implementations that are not selected
+
+ # Always disable PyQt5
+ sed \
+ -e '/from PyQt5.QtCore import/,/)/c\ \ \ \ \ \ \ \ raise ImportError #/' \
+ -e '/if "PyQt5" in sys.modules:/,/"pyqt5"/c\' \
+ -i qtpy/__init__.py || die
+
+ # We need to ensure the first option is an 'if' not 'elif'
+ sed -e 's/elif "PySide2" in sys.modules:/if "PySide2" in sys.modules:/g' \
+ -i qtpy/__init__.py || die
+
+ # Always disable PySide2
+ sed \
+ -e "s/from PySide2 import/raise ImportError #/" \
+ -e "s/from PySide2.QtCore import/raise ImportError #/" \
+ -e '/if "PySide2" in sys.modules:/,/"pyside2"/c\' \
+ -i qtpy/__init__.py || die
+
+ sed \
+ -e 's/elif "PyQt6" in sys.modules:/if "PyQt6" in sys.modules:/g' \
+ -i qtpy/__init__.py || die
+
+ if ! use pyqt6; then
+ sed \
+ -e '/from PyQt6.QtCore import/,/)/c\ \ \ \ \ \ \ \ raise ImportError #/' \
+ -e '/if "PyQt6" in sys.modules:/,/"pyqt6"/c\' \
+ -i qtpy/__init__.py || die
+
+ sed \
+ -e 's/elif "PySide6" in sys.modules:/if "PySide6" in sys.modules:/g' \
+ -i qtpy/__init__.py || die
+ fi
+ if ! use pyside6; then
+ sed \
+ -e "s/from PySide6 import/raise ImportError #/" \
+ -e "s/from PySide6.QtCore import/raise ImportError #/" \
+ -e '/if "PySide6" in sys.modules:/,/"pyside6"/c\' \
+ -i qtpy/__init__.py || die
+ fi
+}
+
+python_test() {
+ local -x QT_API
+ local -a EPYTEST_DESELECT
+ local other
+
+ # Test for each enabled Qt4Python target.
+ # Deselect the other targets, their test fails if we specify QT_API
+ # or if we have disabled their corresponding inherit in __init__.py above
+ for QT_API in PyQt6 PySide6; do
+ if use "${QT_API,,}"; then
+ EPYTEST_DESELECT=()
+ for other in PyQt{5,6} PySide{2,6}; do
+ if [[ ${QT_API} != ${other} ]]; then
+ EPYTEST_DESELECT+=(
+ "qtpy/tests/test_main.py::test_qt_api_environ[${other}]"
+ )
+ fi
+ done
+
+ einfo "Testing with ${EPYTHON} and QT_API=${QT_API}"
+ nonfatal epytest -o addopts= ||
+ die -n "Tests failed with ${EPYTHON} and QT_API=${QT_API}" ||
+ return 1
+ fi
+ done
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+pkg_postinst() {
+ elog "When multiple Qt4Python targets are enabled QtPy will default to"
+ elog "the first enabled target in this order: PyQt6 PySide6."
+ elog "This can be overridden with the QT_API environment variable."
+}