summaryrefslogtreecommitdiff
path: root/dev-python/random2/random2-1.0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-python/random2/random2-1.0.1-r1.ebuild
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-python/random2/random2-1.0.1-r1.ebuild')
-rw-r--r--dev-python/random2/random2-1.0.1-r1.ebuild16
1 files changed, 16 insertions, 0 deletions
diff --git a/dev-python/random2/random2-1.0.1-r1.ebuild b/dev-python/random2/random2-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..59faaf8a32c4
--- /dev/null
+++ b/dev-python/random2/random2-1.0.1-r1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Python-2.7 random module ported to python-3"
+HOMEPAGE="https://pypi.org/project/random2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"