summaryrefslogtreecommitdiff
path: root/dev-python/ratelimit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-22 11:09:47 +0100
commit64e107b9b6058580ff0432107eb37cefb0b2a7d8 (patch)
tree9a44e603e2ae365e2b1fe35ac37f73e830cdee1d /dev-python/ratelimit
parent957235cf19a691360c720f7913672adda4258ed0 (diff)
gentoo resync : 22.10.2018
Diffstat (limited to 'dev-python/ratelimit')
-rw-r--r--dev-python/ratelimit/Manifest2
-rw-r--r--dev-python/ratelimit/ratelimit-1.4.1.ebuild15
2 files changed, 10 insertions, 7 deletions
diff --git a/dev-python/ratelimit/Manifest b/dev-python/ratelimit/Manifest
index 637f4e70e462..3350d2236ca2 100644
--- a/dev-python/ratelimit/Manifest
+++ b/dev-python/ratelimit/Manifest
@@ -1,3 +1,3 @@
DIST ratelimit-1.4.1.tar.gz 10700 BLAKE2B d2fc1b0695c6bdc7653862ca790e9f5ec87b25513a93ec058384f334b47d5080570e3511eb6680b934b345ef5562771a078fc4ced3ceed263a7aafd26af3bfdd SHA512 ab8a2cc95b852f91c614ba5a5a677d2b4b99d5f810ec8a11e69d97af58cef1f67457e1cf686a286073c85b39c2ebbeca0a459382e410c9e8eda12cecdda57f02
-EBUILD ratelimit-1.4.1.ebuild 566 BLAKE2B df2d66c46e4f034f22b058f533d763fe46c16d9675c3e1d5c726ca5985d0b97411b524892063618e67c259fc276dea7d961d17eaaf088fc26c5e63d7de24df61 SHA512 a8445d5d480db02949c0693b1e75ba44dcbaf474a7bfbd7b4aed8644c6ac1204e2278a10944ee9efe809e97cac777ebaa43b06990506669b6a899ab474e33ece
+EBUILD ratelimit-1.4.1.ebuild 598 BLAKE2B 1b5dad627c07655f69354a70114b93faf6b94cad0df5dea39284783d8a90f6f1596e8afc5f482f44ba8de93d581dcdf4ae6520401a89c5237e18ffa39964cc05 SHA512 5dca945ffe22dba01415ba5b3d9992f63d4c5aa5135450921dcc9af52d51f71c5e7a5a12f6d561712288f72058a5688f5ad001387bb1f44518a1d4a38981a451
MISC metadata.xml 724 BLAKE2B 2ebbc8dbd58619d4978081c22d294e19682a10a159321b143e942e4a4f969400792a411fb6db3670d747fea6747927030d590c45251e753ff5183be3667297e8 SHA512 aec024dc134acf8c02150822fdd1b29ac3042aac96a5a54d5c1876e20bd4bf4bd2211374460b8dd4c19b37be44d063b5cd36ac77f196c30b4529c65bd7c45249
diff --git a/dev-python/ratelimit/ratelimit-1.4.1.ebuild b/dev-python/ratelimit/ratelimit-1.4.1.ebuild
index 3c01b8f2c100..e91d5f08f03e 100644
--- a/dev-python/ratelimit/ratelimit-1.4.1.ebuild
+++ b/dev-python/ratelimit/ratelimit-1.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,11 +16,14 @@ KEYWORDS="~amd64 ~x86"
IUSE="test"
DEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- )"
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ default
+ # remove --cov args injection
+ rm pytest.ini || die
+}
python_test() {
- py.test || die
+ pytest || die
}