summaryrefslogtreecommitdiff
path: root/dev-python/requests-cache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-30 07:22:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-30 07:22:57 +0000
commit3059f20995d5ac642b7b4a38d538fdf1cc45d90d (patch)
tree8d4c6b1c09f03338eef1359de3dfeec28ea11644 /dev-python/requests-cache
parentf616ce4660c92a3fcb4f05663c2ab47c9defa0c3 (diff)
gentoo auto-resync : 30:11:2022 - 07:22:56
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/Manifest2
-rw-r--r--dev-python/requests-cache/requests-cache-0.9.6.ebuild71
2 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/requests-cache/Manifest b/dev-python/requests-cache/Manifest
index 67fd61a26313..7d2284197050 100644
--- a/dev-python/requests-cache/Manifest
+++ b/dev-python/requests-cache/Manifest
@@ -1,5 +1,3 @@
-DIST requests-cache-0.9.6.gh.tar.gz 1514642 BLAKE2B 1b098b14a677976b1e767e63b8b5f6c1a3e89b5023b6150f0d186aefe0dad14ad9999e1b036b436759ec4b27b6663159d2a8538dbf99a9017c18a34f0c117d94 SHA512 88e4745bed278224ccd1eb815a4f9da84051bab79c43122fa97899c3a8ad87ad7bfd929f87680eb6f73b1ff14267d2519afd9ef8815f10597769cab8ada7f8b5
DIST requests-cache-0.9.7.gh.tar.gz 1544100 BLAKE2B a255d3cce0345ff03e020327c10a1d8cc25e519069764b7e3e1a43a0e5cd899aec824e3c147561796cba1f269550505f881cf913d909ce7e6c52e8f76ad9688a SHA512 00b2c7080030ed07f5d896871a431aec2625dab6ab84f01f7e6fea9e81692f757304e25ee6addbe7695e93d0c1c04484c31b95a71d7c9e12f6c23a5b7747ae30
-EBUILD requests-cache-0.9.6.ebuild 1794 BLAKE2B 63568dc0ba82267a7f895e5a5e425048d04ef7bdcc1c93b9bdacc88ea897910b1d3d91092fd64ec092ea8e1d52923b85f638bcdf90bcca1d4a96feee7dbed037 SHA512 50a21abde50a0317855cab966f8e315d90046e8b6d7e377520586ba1103d4e23974e688a8365ccfca605d9ac84ddffaec15b79b1ddecec347b1872019234d1b8
EBUILD requests-cache-0.9.7.ebuild 1801 BLAKE2B 6895ba7ab3a0479b2dbafde4f6eb60e5a61376da2378e7aab5fcc6eb2f3f3a0abf45a893a611892c6b6f4edb138240fcdac9aa958298dfed027b6d79bb17f5bf SHA512 ff6afd5c45ec4f46e09eeef6b6fbb74fd8fd0c14e42507eb9b56bcbc070f8bd4671d25493802cc40621d4624fb5d8f31b184ae7a09cb607021146e129643261c
MISC metadata.xml 541 BLAKE2B a8fd81921a36e2fe5bdec38cc1039b9e91971c992a59cbe2dc4826977f753bd6cd2533f65b5f1a076308a898972fe70e85a2c8cf480259e9801f51b10c4de8a4 SHA512 64f29b67eaf3ce892a9f918abd7eaf8f020323e9e0d986b424cffc83e3ac1ba5cb14b534f0a0ec73a8e81694ca4e0e7f98ef02968ac5b43dab104b2b12e8e0f2
diff --git a/dev-python/requests-cache/requests-cache-0.9.6.ebuild b/dev-python/requests-cache/requests-cache-0.9.6.ebuild
deleted file mode 100644
index dfe56be308eb..000000000000
--- a/dev-python/requests-cache/requests-cache-0.9.6.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1 optfeature
-
-HOMEPAGE="
- https://pypi.org/project/requests-cache/
- https://github.com/requests-cache/requests-cache/
-"
-DESCRIPTION="Persistent cache for requests library"
-SRC_URI="
- https://github.com/requests-cache/requests-cache/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/appdirs[${PYTHON_USEDEP}]
- dev-python/cattrs[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- dev-python/timeout-decorator[${PYTHON_USEDEP}]
- dev-python/ujson[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # These require extra servers running
- tests/integration/test_dynamodb.py
- tests/integration/test_gridfs.py
- tests/integration/test_mongodb.py
- tests/integration/test_redis.py
- )
- local EPYTEST_DESELECT=(
- # Requires Internet access
- tests/integration/test_compat.py::test_version_upgrade
- )
-
- local -x USE_PYTEST_HTTPBIN=true
- epytest
-}
-
-pkg_postinst() {
- optfeature "redis backend" "dev-python/redis-py"
- optfeature "MongoDB backend" "dev-python/pymongo"
-
- optfeature "JSON serialization" "dev-python/ujson"
- optfeature "YAML serialization" "dev-python/pyyaml"
- optfeature "signing serialized data" "dev-python/itsdangerous"
-}