summaryrefslogtreecommitdiff
path: root/dev-python/requests-cache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-01 07:44:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-01 07:44:56 +0100
commit910ec713340312b0b8437a7307c8effaa33fb410 (patch)
tree6223bae8a96d9bc13138d3a595aeda9182e64094 /dev-python/requests-cache
parent7714c84b341b3c783197e342fda2df5e579ac91f (diff)
gentoo auto-resync : 01:07:2023 - 07:44:56
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/Manifest2
-rw-r--r--dev-python/requests-cache/requests-cache-1.1.0.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/requests-cache/Manifest b/dev-python/requests-cache/Manifest
index 439f369ea7eb..a8a7fbefb441 100644
--- a/dev-python/requests-cache/Manifest
+++ b/dev-python/requests-cache/Manifest
@@ -1,3 +1,5 @@
DIST requests-cache-1.0.1.gh.tar.gz 2914175 BLAKE2B b1c3c544a761e127204172381a66b0175f09e49040a7d0f04760cf03b253846ac7e831b7c15d4b128e47e5bc132ea3493eba2784ac442be4dc0eab262e2251b0 SHA512 ec5788e31f60fd95e575d01af1163f981757972db6557d7a62da2ca0719e84262cf66cdd9b40c73cca540b92d6b7f6beba1aa42bedba528734c61edf5013ec3d
+DIST requests-cache-1.1.0.gh.tar.gz 2918734 BLAKE2B 4f420a607631568b40999a904598504e0917f50f33715d1d041e0c11dc196abc88cf96ed57860632a1e1f1fb74f3fcabde3df6096821dc0a0967aabca868f7ad SHA512 8fa9fdf4f47d67a6ad877fc181e04378b4540b35cef200735caff14e4907519aa5de74acaf61c6588856d5c8b2f9529768250a8e5fe28962b7861daf2279bb94
EBUILD requests-cache-1.0.1.ebuild 1859 BLAKE2B 7a7db167f03ffc172ef756bf8d5bf80ed18294793a9658b930f92ea5ac2cd542906e4b4f9c6e6ef747e174ddbec30497c6373a864670aa1e0b47f9443c82b6a3 SHA512 7944c319a8e2fc4c2eb8067a18f1f6664ea5a78fea4c76c19ecb521d11cd17dce0d05e753d19ee295c91d6a1f0fe40fb009d5ea76bee4fa2eb21974eb79ce141
+EBUILD requests-cache-1.1.0.ebuild 1948 BLAKE2B f5f1090b7ab7ecb787a772eb843e634c6367d8500e22b8c3c065430aa1f38cb7266807e7aa6caec4ae2e05f9e48c250052ff0e8c1bb78989264247a112c87120 SHA512 719d9a3b8d6ce3cb8fbb77e7258bc5dc430f8291ca90c43489b74c4c6427ee980b3dbcb56bcc89c14e42623e46644e3703e382223a916ead92e4a9dfadc68ed2
MISC metadata.xml 541 BLAKE2B a8fd81921a36e2fe5bdec38cc1039b9e91971c992a59cbe2dc4826977f753bd6cd2533f65b5f1a076308a898972fe70e85a2c8cf480259e9801f51b10c4de8a4 SHA512 64f29b67eaf3ce892a9f918abd7eaf8f020323e9e0d986b424cffc83e3ac1ba5cb14b534f0a0ec73a8e81694ca4e0e7f98ef02968ac5b43dab104b2b12e8e0f2
diff --git a/dev-python/requests-cache/requests-cache-1.1.0.ebuild b/dev-python/requests-cache/requests-cache-1.1.0.ebuild
new file mode 100644
index 000000000000..df0f2285368e
--- /dev/null
+++ b/dev-python/requests-cache/requests-cache-1.1.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 optfeature
+
+HOMEPAGE="
+ https://pypi.org/project/requests-cache/
+ https://github.com/requests-cache/requests-cache/
+"
+DESCRIPTION="Persistent cache for requests library"
+SRC_URI="
+ https://github.com/requests-cache/requests-cache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/cattrs-22.2[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.5[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+ >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/rich-10.0[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ >=dev-python/ujson-5.4[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/time-machine[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # These require extra servers running
+ tests/integration/test_dynamodb.py
+ tests/integration/test_gridfs.py
+ tests/integration/test_mongodb.py
+ tests/integration/test_redis.py
+ )
+ local EPYTEST_DESELECT=(
+ # Requires Internet access
+ tests/integration/test_upgrade.py::test_version_upgrade
+ )
+
+ local -x USE_PYTEST_HTTPBIN=true
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "redis backend" "dev-python/redis"
+ optfeature "MongoDB backend" "dev-python/pymongo"
+
+ optfeature "JSON serialization" "dev-python/ujson"
+ optfeature "YAML serialization" "dev-python/pyyaml"
+ optfeature "signing serialized data" "dev-python/itsdangerous"
+}