summaryrefslogtreecommitdiff
path: root/dev-python/requests-mock/requests-mock-1.9.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-08 15:03:58 +0100
commit814f4cf860e299a046b649eaee5463427984c09c (patch)
tree74c45f097899310e599dad6b8df5b63e0f085bc0 /dev-python/requests-mock/requests-mock-1.9.3.ebuild
parent7f0ccc917c7abe6223784c703d86cd14755691fb (diff)
gentoo resync : 08.07.2021
Diffstat (limited to 'dev-python/requests-mock/requests-mock-1.9.3.ebuild')
-rw-r--r--dev-python/requests-mock/requests-mock-1.9.3.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-python/requests-mock/requests-mock-1.9.3.ebuild b/dev-python/requests-mock/requests-mock-1.9.3.ebuild
index db7c8a5091b8..ecf8e6aa4b5d 100644
--- a/dev-python/requests-mock/requests-mock-1.9.3.ebuild
+++ b/dev-python/requests-mock/requests-mock-1.9.3.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{7..9} )
+EAPI=8
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Mock out responses from the requests package"
@@ -13,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
RDEPEND="
>=dev-python/requests-2.3[${PYTHON_USEDEP}]
@@ -30,7 +29,7 @@ BDEPEND="
"
distutils_enable_sphinx doc/source
-distutils_enable_tests unittest
+distutils_enable_tests pytest
python_prepare_all() {
# Disable reno which only works inside a git repository